summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-01-01 17:18:18 +0100
committerDavid Seifert <soap@gentoo.org>2023-01-01 17:18:18 +0100
commit1087ed467565c2ca78e3cfde6a8478bf98e48603 (patch)
tree0bf0e00369d6feeef91211f2d1fa7f57d30bd04b
parentnet-libs/uhttpmock: move vala deps to BDEPEND (diff)
downloadgentoo-1087ed46.tar.gz
gentoo-1087ed46.tar.bz2
gentoo-1087ed46.zip
net-libs/telepathy-glib: update EAPI 7 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--net-libs/telepathy-glib/telepathy-glib-0.24.2-r1.ebuild (renamed from net-libs/telepathy-glib/telepathy-glib-0.24.2.ebuild)19
1 files changed, 6 insertions, 13 deletions
diff --git a/net-libs/telepathy-glib/telepathy-glib-0.24.2.ebuild b/net-libs/telepathy-glib/telepathy-glib-0.24.2-r1.ebuild
index 2ec67e1d4063..c6d29d9f69ee 100644
--- a/net-libs/telepathy-glib/telepathy-glib-0.24.2.ebuild
+++ b/net-libs/telepathy-glib/telepathy-glib-0.24.2-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_REQ_USE="xml(+)"
PYTHON_COMPAT=( python3_{8..11} )
@@ -15,10 +15,8 @@ SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-
IUSE="debug +introspection +vala"
REQUIRED_USE="vala? ( introspection )"
-
# Broken for a long time and upstream doesn't care
# https://bugs.freedesktop.org/show_bug.cgi?id=63212
RESTRICT="test"
@@ -28,29 +26,24 @@ RDEPEND="
>=dev-libs/dbus-glib-0.90
introspection? ( >=dev-libs/gobject-introspection-1.30 )
"
-DEPEND="${RDEPEND}
- vala? ( $(vala_depend) )
-"
+DEPEND="${RDEPEND}"
BDEPEND="
${PYTHON_DEPS}
dev-libs/libxslt
dev-util/glib-utils
dev-util/gtk-doc-am
virtual/pkgconfig
+ vala? ( $(vala_depend) )
"
# See bug 504744 for reference
PDEPEND="
net-im/telepathy-mission-control
"
-src_prepare() {
- use vala && vala_src_prepare
- gnome2_src_prepare
-}
-
src_configure() {
+ use vala && vala_setup
+
gnome2_src_configure \
- --disable-static \
--disable-installed-tests \
$(use_enable debug backtrace) \
$(use_enable debug debug-cache) \