summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-07-02 12:39:53 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-07-02 12:42:18 +0200
commit108a30eff5e383a41da0285e07d44ed74eb40c88 (patch)
treecb3975680ed8b678d5485771db2074040724aa84
parentapp-emulation/qemu: I'll keep an eye on qemu (maintain) (diff)
downloadgentoo-108a30ef.tar.gz
gentoo-108a30ef.tar.bz2
gentoo-108a30ef.zip
media-sound/clementine: Fixed build with gcc11
Thanks-to: Jiří Moravec <qjim@volny.cz> Closes: https://bugs.gentoo.org/788607 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--media-sound/clementine/clementine-1.4.0_rc1.ebuild1
-rw-r--r--media-sound/clementine/files/clementine-1.4.0_rc1-gcc11-fix-static-assertion-failure.patch70
2 files changed, 71 insertions, 0 deletions
diff --git a/media-sound/clementine/clementine-1.4.0_rc1.ebuild b/media-sound/clementine/clementine-1.4.0_rc1.ebuild
index ef72ab5c0af0..620d245f5d3a 100644
--- a/media-sound/clementine/clementine-1.4.0_rc1.ebuild
+++ b/media-sound/clementine/clementine-1.4.0_rc1.ebuild
@@ -108,6 +108,7 @@ DOCS=( Changelog README.md )
PATCHES=(
"${FILESDIR}/${P}-QPainterPath_include.patch" #725678
+ "${FILESDIR}/${P}-gcc11-fix-static-assertion-failure.patch" #788607
)
src_prepare() {
diff --git a/media-sound/clementine/files/clementine-1.4.0_rc1-gcc11-fix-static-assertion-failure.patch b/media-sound/clementine/files/clementine-1.4.0_rc1-gcc11-fix-static-assertion-failure.patch
new file mode 100644
index 000000000000..1a492fe5664c
--- /dev/null
+++ b/media-sound/clementine/files/clementine-1.4.0_rc1-gcc11-fix-static-assertion-failure.patch
@@ -0,0 +1,70 @@
+From cfcd0a956e6758624fab0ff20aee9eb08b3df0b3 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Robert-Andr=C3=A9=20Mauchin?= <zebob.m@gmail.com>
+Date: Wed, 16 Dec 2020 20:03:26 +0100
+Subject: [PATCH] Drop -std=c++0x and -U__STRICT_ANSI__
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This was causing compilation failures, static assertion failed, with GCC 11.
+
+Fix #6865
+
+Signed-off-by: Robert-André Mauchin <zebob.m@gmail.com>
+---
+ ext/clementine-spotifyblob/CMakeLists.txt | 2 +-
+ ext/clementine-tagreader/CMakeLists.txt | 2 +-
+ src/CMakeLists.txt | 2 +-
+ tests/CMakeLists.txt | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/ext/clementine-spotifyblob/CMakeLists.txt b/ext/clementine-spotifyblob/CMakeLists.txt
+index e5342ee5b..6fd551d57 100644
+--- a/ext/clementine-spotifyblob/CMakeLists.txt
++++ b/ext/clementine-spotifyblob/CMakeLists.txt
+@@ -7,7 +7,7 @@ include_directories(${CMAKE_SOURCE_DIR}/ext/libclementine-spotifyblob)
+ include_directories(${CMAKE_SOURCE_DIR}/ext/libclementine-common)
+ include_directories(${CMAKE_SOURCE_DIR}/src)
+
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Woverloaded-virtual -Wall -Wno-sign-compare -Wno-deprecated-declarations -Wno-unused-local-typedefs -Wno-unused-private-field -Wno-unknown-warning-option --std=c++0x -U__STRICT_ANSI__")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Woverloaded-virtual -Wall -Wno-sign-compare -Wno-deprecated-declarations -Wno-unused-local-typedefs -Wno-unused-private-field -Wno-unknown-warning-option")
+
+ link_directories(${SPOTIFY_LIBRARY_DIRS})
+
+diff --git a/ext/clementine-tagreader/CMakeLists.txt b/ext/clementine-tagreader/CMakeLists.txt
+index 855e390cf..a48b01450 100644
+--- a/ext/clementine-tagreader/CMakeLists.txt
++++ b/ext/clementine-tagreader/CMakeLists.txt
+@@ -7,7 +7,7 @@ include_directories(${CMAKE_BINARY_DIR}/ext/libclementine-tagreader)
+ include_directories(${CMAKE_SOURCE_DIR}/src)
+ include_directories(${CMAKE_BINARY_DIR}/src)
+
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --std=c++0x -U__STRICT_ANSI__")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}")
+
+ set(EXECUTABLE_OUTPUT_PATH ${CMAKE_BINARY_DIR})
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 627b2e7cb..0bbc775ba 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -1,6 +1,6 @@
+
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Woverloaded-virtual -Wall -Wno-sign-compare -Wno-deprecated-declarations -Wno-unused-local-typedefs -Wno-unused-private-field -Wno-unknown-warning-option --std=c++0x -U__STRICT_ANSI__")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Woverloaded-virtual -Wall -Wno-sign-compare -Wno-deprecated-declarations -Wno-unused-local-typedefs -Wno-unused-private-field -Wno-unknown-warning-option")
+
+ option(BUILD_WERROR "Build with -Werror" ON)
+
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index 4474e7be5..ff571fc19 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -1,6 +1,6 @@
+ cmake_minimum_required(VERSION 2.8.11)
+
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x -fpermissive -Wno-c++11-narrowing -U__STRICT_ANSI__")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fpermissive -Wno-c++11-narrowing")
+
+ if(USE_SYSTEM_GMOCK)
+ include_directories(${GMOCK_INCLUDE_DIRS} ${GTEST_INCLUDE_DIRS})