summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-09 19:31:14 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-09 19:52:51 +0100
commit10916b599860642e7c9a7e9edc777aab30c91ed1 (patch)
tree51bac51ec141b690d9793a69d646873bf213a820
parentdev-python/trove-classifiers: Bump to 2023.11.9 (diff)
downloadgentoo-10916b599860642e7c9a7e9edc777aab30c91ed1.tar.gz
gentoo-10916b599860642e7c9a7e9edc777aab30c91ed1.tar.bz2
gentoo-10916b599860642e7c9a7e9edc777aab30c91ed1.zip
dev-python/pydantic-core: Bump to 2.14.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pydantic-core/Manifest1
-rw-r--r--dev-python/pydantic-core/pydantic-core-2.14.1.ebuild150
2 files changed, 151 insertions, 0 deletions
diff --git a/dev-python/pydantic-core/Manifest b/dev-python/pydantic-core/Manifest
index 316927360759..5920282a31fd 100644
--- a/dev-python/pydantic-core/Manifest
+++ b/dev-python/pydantic-core/Manifest
@@ -46,6 +46,7 @@ DIST pydantic_core-2.10.1.tar.gz 347316 BLAKE2B 782daaae0781da0abfa48056a9eebc86
DIST pydantic_core-2.11.0.tar.gz 351430 BLAKE2B 6471e17df66f7e6134724bfe6d697869c936a3a5603bef08286fe86a4039fa155cbb65c9255b827f9c974321394caca62634b811cac01bdb622d31438a5c719c SHA512 f66ad263f3b0608064173fc15cd7595c7a1ce8b53419280d00435acaba989411bf403667be246ec5da1b3e4f6cf97d413eec8ce810a648d332b2042ea2e51661
DIST pydantic_core-2.12.0.tar.gz 357459 BLAKE2B bbe40de673aa4da4ab0fe935dc6c9cab447ab079cdd251d1e5998451d42b96b40ddc5d34028a64acad9a35a9609b6e2e7a268f210c00c9414a9ffdb36e790d74 SHA512 6c75b1881d032e02dba93012e10390a861be449f8b6b65479eb782517defac82c3a56f94755560506c359cacb66be0f7054c546aa81e6c698023f5dbd1a9bbee
DIST pydantic_core-2.13.0.tar.gz 357396 BLAKE2B a07b37097c886718a4912870affc3401e55c7d7ce921186f3fccff9be30cc8cf4fcf241e3646a4e87983ca249421b3e9eab0408797af1c8755daa02359de3fac SHA512 18dd1c0b9affbaf1050b53a09083fc2e4cabe278ef71fb48b5cbc72d91c6f7fc4bfb7c8737cfc2aa329773e98a4eeeeaaef4da9ad6b40d25840dd4baa1ee280c
+DIST pydantic_core-2.14.1.tar.gz 359077 BLAKE2B 61d58100898f2b1d05b2827fff4ae190f61ad7268aa3d5490f356e7eadaa5a921ff6260baf10ea1e5013272547b7090f985b6ac30aed29847d1aee53a4f1ef7c SHA512 e3c6926d691f6f62d8c4376c39e216c7e8c72aa7bb193869f5e454cc6648f1403e5e138fb09bd99f6c540cf9980a806020860cbae77e1aa481acb296ccfa844a
DIST pydantic_core-2.6.3.tar.gz 337231 BLAKE2B 942a12228ad46d4b5365c781f8f7be28266c54e29bf5ab21e49ef31d25319d065c2f5f0bdc2ccca77888d38cfdea90fb2b415a0c203d8ae62825fb3ef618e1fb SHA512 5123fb55b002bc857ec03239163a5517709ea84430ac7b92d2027bdfbdba278d37caaa0d017d89af8e5306296667d7eb500bfc536a769d99c662b3fbb3835b63
DIST pyo3-0.19.2.crate 418228 BLAKE2B ee018b33383fada78cd22643aea9231a8c8a2f19d1eb297f40eec9206c5220f322fff4c926d939a93a24ac6d231a207ebb25afcc0709191151c7ed9af7465efa SHA512 58698183e0f2f0507f8f765bf3e90185c933e78d62f0a9be65c4b1ce8eea19a98fe0341abe7c58cafdacb63a012ec417876dccb7be6facc1360fcb22796fcaf9
DIST pyo3-0.20.0.crate 431766 BLAKE2B 104bc21ce2c6931753ca0c7b2d91693f454c964260ca3c4628a899fc8e7edbe4238db913ed7356f3beff154d88a60a17c0e252b655768e75483e1d9d9b86f40b SHA512 85d9533c75f905752c62f6a4898582ae48daf085e287b44949c47260301205a5f00477927877ce46300d2801d22fbc04a958c058a37eb28374c834fff27feca1
diff --git a/dev-python/pydantic-core/pydantic-core-2.14.1.ebuild b/dev-python/pydantic-core/pydantic-core-2.14.1.ebuild
new file mode 100644
index 000000000000..3bcf3f7ab143
--- /dev/null
+++ b/dev-python/pydantic-core/pydantic-core-2.14.1.ebuild
@@ -0,0 +1,150 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=maturin
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+CRATES="
+ ahash@0.8.6
+ aho-corasick@1.0.2
+ autocfg@1.1.0
+ base64@0.21.5
+ bitflags@1.3.2
+ cc@1.0.79
+ cfg-if@1.0.0
+ enum_dispatch@0.3.12
+ equivalent@1.0.1
+ form_urlencoded@1.2.0
+ getrandom@0.2.10
+ hashbrown@0.14.0
+ heck@0.4.1
+ idna@0.4.0
+ indexmap@2.0.0
+ indoc@2.0.4
+ itoa@1.0.8
+ jiter@0.0.4
+ lexical-core@0.8.5
+ lexical-parse-float@0.8.5
+ lexical-parse-integer@0.8.6
+ lexical-util@0.8.5
+ lexical-write-float@0.8.5
+ lexical-write-integer@0.8.5
+ libc@0.2.147
+ lock_api@0.4.10
+ memchr@2.6.3
+ memoffset@0.9.0
+ num-bigint@0.4.4
+ num-integer@0.1.45
+ num-traits@0.2.16
+ once_cell@1.18.0
+ parking_lot@0.12.1
+ parking_lot_core@0.9.8
+ percent-encoding@2.3.0
+ proc-macro2@1.0.69
+ pyo3-build-config@0.20.0
+ pyo3-ffi@0.20.0
+ pyo3-macros-backend@0.20.0
+ pyo3-macros@0.20.0
+ pyo3@0.20.0
+ python3-dll-a@0.2.9
+ quote@1.0.29
+ redox_syscall@0.3.5
+ regex-automata@0.4.3
+ regex-syntax@0.8.2
+ regex@1.10.2
+ rustversion@1.0.13
+ ryu@1.0.14
+ scopeguard@1.1.0
+ serde@1.0.190
+ serde_derive@1.0.190
+ serde_json@1.0.108
+ smallvec@1.11.1
+ speedate@0.13.0
+ static_assertions@1.1.0
+ strum@0.25.0
+ strum_macros@0.25.3
+ syn@2.0.38
+ target-lexicon@0.12.9
+ tinyvec@1.6.0
+ tinyvec_macros@0.1.1
+ unicode-bidi@0.3.13
+ unicode-ident@1.0.10
+ unicode-normalization@0.1.22
+ unindent@0.2.3
+ url@2.4.1
+ uuid@1.5.0
+ version_check@0.9.4
+ wasi@0.11.0+wasi-snapshot-preview1
+ windows-targets@0.48.1
+ windows_aarch64_gnullvm@0.48.0
+ windows_aarch64_msvc@0.48.0
+ windows_i686_gnu@0.48.0
+ windows_i686_msvc@0.48.0
+ windows_x86_64_gnu@0.48.0
+ windows_x86_64_gnullvm@0.48.0
+ windows_x86_64_msvc@0.48.0
+ zerocopy-derive@0.7.20
+ zerocopy@0.7.20
+"
+
+inherit cargo distutils-r1 pypi
+
+DESCRIPTION="Core validation logic for pydantic written in Rust"
+HOMEPAGE="
+ https://github.com/pydantic/pydantic-core/
+ https://pypi.org/project/pydantic-core/
+"
+SRC_URI+="
+ ${CARGO_CRATE_URIS}
+"
+
+LICENSE="MIT"
+# Dependent crate licenses
+LICENSE+="
+ Apache-2.0-with-LLVM-exceptions MIT Unicode-DFS-2016
+ || ( Apache-2.0 Boost-1.0 )
+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/typing-extensions-4.7.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=virtual/rust-1.70.0
+ test? (
+ >=dev-python/dirty-equals-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-6.63.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-1.10.4[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2022.7.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+QA_FLAGS_IGNORED="usr/lib.*/py.*/site-packages/pydantic_core/_pydantic_core.*.so"
+
+src_prepare() {
+ sed -i -e '/--benchmark/d' pyproject.toml || die
+ sed -i -e '/^strip/d' Cargo.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/benchmarks
+ )
+ local EPYTEST_DESELECT=(
+ # TODO: recursion till segfault
+ tests/serializers/test_functions.py::test_recursive_call
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ rm -rf pydantic_core || die
+ epytest -p pytest_mock -p timeout
+}