summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-21 10:01:46 +0000
committerSam James <sam@gentoo.org>2024-02-21 10:02:18 +0000
commit10ae775c02c00f9a03ff41c799cbe13342a3b81f (patch)
treea71c115182cc0b99a6a63c6231fce33a94b684a9
parentwww-servers/lighttpd: add 1.4.74 (diff)
downloadgentoo-10ae775c02c00f9a03ff41c799cbe13342a3b81f.tar.gz
gentoo-10ae775c02c00f9a03ff41c799cbe13342a3b81f.tar.bz2
gentoo-10ae775c02c00f9a03ff41c799cbe13342a3b81f.zip
sys-apps/moar: add 1.23.6
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/moar/Manifest2
-rw-r--r--sys-apps/moar/moar-1.23.6.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index 9b856b6deb06..be255952b91f 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -2,3 +2,5 @@ DIST moar-1.22.3-deps.tar.xz 61027724 BLAKE2B ba22db246b20f4a6b28c19a3654f1b1cd6
DIST moar-1.22.3.tar.gz 2799819 BLAKE2B 681297e9a84f6846d7ea6cd591403fd3100079fc8418ce5841a50755927239eca5abbfc0477d1a74e3af687ef1ebe372d4f708c38a64ba61b3095ac161f1cb8e SHA512 377cdf4916b036088f48abd4aa9818f002dd5ab025a54f4d91626380bb3d370daf046da6f3dc31fcc11a375d7da1a84288fb3e2e3357181a6ecc6a46af78c452
DIST moar-1.23.4-deps.tar.xz 61027724 BLAKE2B ba22db246b20f4a6b28c19a3654f1b1cd68e0a92aff43ff02a592b303ff3318c3766381bd4b0abff5f479fe571b753a272213d7dc7da809a33ded36228dac100 SHA512 a1be9f66480867faa06fb451bcc6a294bb1e2e4601c97c1beac67a3f866104b196ecd2653dc9ddd48a5223d4f3067a01abbaf45fc07333d97c4f8489424ff5cf
DIST moar-1.23.4.tar.gz 2801843 BLAKE2B 93b0ce5159d0b3b244716e0643f2ff9ac27f7179ab116a3be037c5efc16d78e37e92c2367181ecc28e641048b3768acf584911acee1c8f4eeee28ad32f574bba SHA512 55e2d24d8ccef2d8b0582027b70527500aec9fc24f8dd03a90677e2743742f9fa0e664e5cad6a8630d8bb47b402ef54778a4efc656b102afec7578ffd62d3bfe
+DIST moar-1.23.6-deps.tar.xz 61017844 BLAKE2B 40df3ea571741c31b7ca464f57524db13938af1dbd191e59110434b7c3447ff44e4eb44c5a3596a81404e3478d62172e00f8a216eec7902c57d9ae8d96fdd7c7 SHA512 555ebe9819424f6558ce30dc1cfe9d2408e416079b7d9e15d091f7ab83686a102fb02ac3f843874c855c548d0691633b3eaee3ec261a54f43f015ec7e7d25d43
+DIST moar-1.23.6.tar.gz 2801847 BLAKE2B d9e638d15ac363d3787fcce4bdc640c497a400ecaf5f40763dd8efed28cc3f5e479733d4b1f9a457395e4b9dda844748459a07fa674f50e3d6b630755af3ac4f SHA512 94103263f2c07464fbc0c5a90519a3a03ef5f163a67ca451a703c11bf46b98011b6e29a038b08bb47dc08230c28ae822ced49f2aec2bf8b6e83c6a4c1f330aa4
diff --git a/sys-apps/moar/moar-1.23.6.ebuild b/sys-apps/moar/moar-1.23.6.ebuild
new file mode 100644
index 000000000000..7ba82f9aa27b
--- /dev/null
+++ b/sys-apps/moar/moar-1.23.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI="https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# moarvm: https://github.com/walles/moar/issues/143
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}