summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-01 00:19:57 +0100
committerSam James <sam@gentoo.org>2021-04-01 22:17:07 +0100
commit10c2f5e418230f74c29ee7338a7369fb1b27d351 (patch)
tree21884c7cb2ca53c9ffdc572cc3f8850f291f18d1
parentdev-libs/libvterm: fix MissingInherits (toolchain-funcs) (diff)
downloadgentoo-10c2f5e4.tar.gz
gentoo-10c2f5e4.tar.bz2
gentoo-10c2f5e4.zip
app-accessibility/yasr: port to EAPI 7, fix Prefix install
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-accessibility/yasr/yasr-0.6.9-r1.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/app-accessibility/yasr/yasr-0.6.9-r1.ebuild b/app-accessibility/yasr/yasr-0.6.9-r1.ebuild
index b9e8c1573d6e..1c7e089be171 100644
--- a/app-accessibility/yasr/yasr-0.6.9-r1.ebuild
+++ b/app-accessibility/yasr/yasr-0.6.9-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools
@@ -14,8 +14,7 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="nls"
-RDEPEND=""
-DEPEND="nls? ( sys-devel/gettext )"
+BDEPEND="nls? ( sys-devel/gettext )"
PATCHES=(
"${FILESDIR}"/${PN}-0.6.9-automake113.patch
@@ -26,8 +25,10 @@ PATCHES=(
src_prepare() {
default
- local x=/usr/share/gettext/po/Makefile.in.in
- [[ -e $x ]] && cp -f $x po/ || die #330879
+
+ local x="${BROOT}"/usr/share/gettext/po/Makefile.in.in
+ # bug 330879
+ [[ -e $x ]] && cp -f $x po/ || die
rm -r "${S}"/m4 || die
@@ -50,5 +51,5 @@ src_configure() {
pkg_postinst() {
elog
elog "Speech-dispatcher is configured as the default synthesizer for yasr."
- elog "If this is not what you want, edit /etc/yasr/yasr.conf."
+ elog "If this is not what you want, edit ${EROOT}/etc/yasr/yasr.conf."
}