summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-08-29 18:26:00 +0100
committerSam James <sam@gentoo.org>2021-08-29 19:33:07 +0100
commit10cc462e684d5aa4b10e1f39d09849401e01f971 (patch)
tree845b17b4cc6ce6f38eb76d4010fa19c588bb7b37
parentx11-terms/zutty: Drop old (diff)
downloadgentoo-10cc462e.tar.gz
gentoo-10cc462e.tar.bz2
gentoo-10cc462e.zip
x11-terms/zutty: Compatibility with >=media-libs/freetype-2.11.0
Closes: https://bugs.gentoo.org/809611 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Closes: https://github.com/gentoo/gentoo/pull/22150 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--x11-terms/zutty/files/zutty-0.9-freetype-2.11.0.patch35
-rw-r--r--x11-terms/zutty/zutty-0.9-r1.ebuild35
2 files changed, 70 insertions, 0 deletions
diff --git a/x11-terms/zutty/files/zutty-0.9-freetype-2.11.0.patch b/x11-terms/zutty/files/zutty-0.9-freetype-2.11.0.patch
new file mode 100644
index 000000000000..b5d62204e6be
--- /dev/null
+++ b/x11-terms/zutty/files/zutty-0.9-freetype-2.11.0.patch
@@ -0,0 +1,35 @@
+From c73c99d6b024047d9f9e53e263be56093b6bf986 Mon Sep 17 00:00:00 2001
+From: Matt Smith <matt@offtopica.uk>
+Date: Sun, 29 Aug 2021 19:15:01 +0100
+Subject: [PATCH] Prevent rendering glyphs twice
+
+Characters are loaded with FT_LOAD_RENDER. Calling FT_Render_Glyph
+again causes an error in Freetype 2.11.0 and later.
+
+Thanks to Stephan Hartmann <sultan@gentoo.org> for debugging and creating initial patch.
+
+Bug: https://bugs.gentoo.org/809611
+---
+ src/font.cc | 6 ------
+ 1 file changed, 6 deletions(-)
+
+diff --git a/src/font.cc b/src/font.cc
+index f8da582..350a1a6 100644
+--- a/src/font.cc
++++ b/src/font.cc
+@@ -255,12 +255,6 @@ namespace zutty
+ std::to_string (c));
+ }
+
+- if (FT_Render_Glyph (face->glyph, FT_RENDER_MODE_NORMAL))
+- throw std::runtime_error (
+- std::string ("FreeType: Failed to render glyph for char ") +
+- std::to_string (c));
+-
+-
+ // destination pixel offset
+ const unsigned int dx = face->glyph->bitmap_left > 0
+ ? face->glyph->bitmap_left : 0;
+--
+2.33.0
+
diff --git a/x11-terms/zutty/zutty-0.9-r1.ebuild b/x11-terms/zutty/zutty-0.9-r1.ebuild
new file mode 100644
index 000000000000..fdcb77c3890b
--- /dev/null
+++ b/x11-terms/zutty/zutty-0.9-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="X terminal emulator rendering through OpenGL ES Compute Shaders"
+HOMEPAGE="https://tomscii.sig7.se/zutty/ https://github.com/tomszilagyi/zutty"
+SRC_URI="https://github.com/tomszilagyi/zutty/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ media-libs/freetype:2
+ media-libs/libglvnd[X]
+ x11-libs/libXmu
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Bug 809611
+ "${FILESDIR}"/${PN}-0.9-freetype-2.11.0.patch
+)
+
+DOCS=( doc/KEYS.org doc/USAGE.org )