summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-03-18 17:42:58 +0100
committerDavid Seifert <soap@gentoo.org>2023-03-18 17:42:58 +0100
commit10d9c4d51552365acac415c4a5af8f34166957db (patch)
tree04b077586a5bb67970eb42c3b24432f421bfb4d9
parentdev-java/spec-alpha: treeclean (diff)
downloadgentoo-10d9c4d5.tar.gz
gentoo-10d9c4d5.tar.bz2
gentoo-10d9c4d5.zip
dev-java/core-specs-alpha: treeclean
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-java/core-specs-alpha/Manifest3
-rw-r--r--dev-java/core-specs-alpha/core-specs-alpha-0.1.24.ebuild41
-rw-r--r--dev-java/core-specs-alpha/core-specs-alpha-0.2.44.ebuild41
-rw-r--r--dev-java/core-specs-alpha/core-specs-alpha-0.2.56.ebuild44
-rw-r--r--dev-java/core-specs-alpha/files/build.xml37
-rw-r--r--dev-java/core-specs-alpha/metadata.xml15
-rw-r--r--profiles/package.mask6
7 files changed, 0 insertions, 187 deletions
diff --git a/dev-java/core-specs-alpha/Manifest b/dev-java/core-specs-alpha/Manifest
deleted file mode 100644
index 077792b32a55..000000000000
--- a/dev-java/core-specs-alpha/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST core-specs-alpha-0.1.24.tar.gz 9896 BLAKE2B cb06053d2aa77b4bbd58b612fb0f80137833e156a5136e4f53f6123d158bdbe676e9bacdfe76728b1320986589e8242c52f49a4d8922bda5374e34fe52969ddc SHA512 6ddf20bf9be36f7493104f69f4e9402fc62f49005471a967843c7cfee898c67aaf5046886db73e6b54942538beed9556d83f4582e85fd02ef4cb755cb5a18d34
-DIST core-specs-alpha-0.2.44.tar.gz 10163 BLAKE2B c81ebb08779c3db137363ffb12bc7e26d29cd67323c98430a033f639714da83bf8c9d14146c12d925094e057d3735d100e33656e9571a0a4c107dc9fb56359e9 SHA512 1a59b947c580e45a280b25d5827a174565e066dde577685ca86aa1bbd9767716991cefb8a944c7ded0f84a71f9902f7fcdb5baacc7e19180096d599a51083048
-DIST core-specs-alpha-0.2.56.tar.gz 11780 BLAKE2B 088d0b32dea7ec49ddaf0f461703762a5a877ff4028b775eb35998e6a5a3436ad57b35d7d9431b6911ca2304403e95043d375bac80080ecaf6144a77b3ebcf4c SHA512 afbfc04b9708a21ae6c6b29b8653fc62b23efcb271b973534c4b8421a7d73df3ad24bd28d7115a2fe926954dc45571de86971637736f3a494799f6f1ba1765c8
diff --git a/dev-java/core-specs-alpha/core-specs-alpha-0.1.24.ebuild b/dev-java/core-specs-alpha/core-specs-alpha-0.1.24.ebuild
deleted file mode 100644
index a04c6e5dd6ac..000000000000
--- a/dev-java/core-specs-alpha/core-specs-alpha-0.1.24.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit java-pkg-2 java-ant-2
-
-EGIT_REF="43815fc"
-
-MY_PN=${PN//-/.}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="A Clojure library with specs to describe Clojure core macros and functions"
-HOMEPAGE="https://clojure.org/ https://github.com/clojure/core.specs.alpha"
-SRC_URI="https://github.com/clojure/${MY_PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="EPL-1.0"
-SLOT="0.1"
-KEYWORDS="~amd64 ~x86 ~x86-linux"
-IUSE=""
-
-CDEPEND="dev-java/ant-core:0"
-RDEPEND=">=virtual/jre-1.8:*"
-DEPEND="
- ${CDEPEND}
- >=virtual/jdk-1.8:*"
-
-S="${WORKDIR}/${MY_PN}-${MY_P}"
-
-EANT_TASKS="jar"
-EANT_EXTRA_ARGS="-Dmaven.build.finalName=${MY_P}"
-
-src_prepare() {
- default
- cp "${FILESDIR}/build.xml" . || die
-}
-
-src_install() {
- java-pkg_newjar "target/${MY_P}.jar"
- dodoc CONTRIBUTING.md README.md
-}
diff --git a/dev-java/core-specs-alpha/core-specs-alpha-0.2.44.ebuild b/dev-java/core-specs-alpha/core-specs-alpha-0.2.44.ebuild
deleted file mode 100644
index f54ad2867014..000000000000
--- a/dev-java/core-specs-alpha/core-specs-alpha-0.2.44.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit java-pkg-2 java-ant-2
-
-EGIT_REF="d69f559"
-
-MY_PN=${PN//-/.}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="A Clojure library with specs to describe Clojure core macros and functions"
-HOMEPAGE="https://clojure.org/ https://github.com/clojure/core.specs.alpha"
-SRC_URI="https://github.com/clojure/${MY_PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="EPL-1.0"
-SLOT="0.2"
-KEYWORDS="~amd64 ~x86 ~x86-linux"
-IUSE=""
-
-CDEPEND="dev-java/ant-core:0"
-RDEPEND=">=virtual/jre-1.8:*"
-DEPEND="
- ${CDEPEND}
- >=virtual/jdk-1.8:*"
-
-S="${WORKDIR}/${MY_PN}-${MY_P}"
-
-EANT_TASKS="jar"
-EANT_EXTRA_ARGS="-Dmaven.build.finalName=${MY_P}"
-
-src_prepare() {
- default
- cp "${FILESDIR}/build.xml" . || die
-}
-
-src_install() {
- java-pkg_newjar "target/${MY_P}.jar"
- dodoc CONTRIBUTING.md README.md
-}
diff --git a/dev-java/core-specs-alpha/core-specs-alpha-0.2.56.ebuild b/dev-java/core-specs-alpha/core-specs-alpha-0.2.56.ebuild
deleted file mode 100644
index 64ba20033302..000000000000
--- a/dev-java/core-specs-alpha/core-specs-alpha-0.2.56.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit java-pkg-2 java-ant-2
-
-EGIT_REF="053d789"
-
-MY_PN=core.specs.alpha
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="A Clojure library with specs to describe Clojure core macros and functions"
-HOMEPAGE="https://clojure.org/ https://github.com/clojure/core.specs.alpha"
-SRC_URI="https://github.com/clojure/core.specs.alpha/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="EPL-1.0"
-SLOT="0.2"
-KEYWORDS="~amd64 ~x86 ~x86-linux"
-
-RDEPEND=">=virtual/jre-1.8:*"
-
-DEPEND="
- dev-java/ant-core:0
- >=virtual/jdk-1.8:*
-"
-
-S="${WORKDIR}/${MY_PN}-${MY_P}"
-
-DOCS=( CONTRIBUTING.md LICENSE README.md )
-
-EANT_TASKS="jar"
-EANT_EXTRA_ARGS="-Dmaven.build.finalName=${MY_P}"
-
-src_prepare() {
- default
- rm -r CHANGES.md epl-v10.html || die # epl-10.html is the LICENSE in html format
- cp "${FILESDIR}/build.xml" . || die
-}
-
-src_install() {
- java-pkg_newjar "target/${MY_P}.jar"
- einstalldocs
-}
diff --git a/dev-java/core-specs-alpha/files/build.xml b/dev-java/core-specs-alpha/files/build.xml
deleted file mode 100644
index 0499525e8817..000000000000
--- a/dev-java/core-specs-alpha/files/build.xml
+++ /dev/null
@@ -1,37 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!-- ====================================================================== -->
-<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
-<!-- ====================================================================== -->
-
-<project name="spec.alpha" default="package" basedir=".">
- <property name="maven.build.finalName" value="core.specs.alpha-SNAPSHOT"/>
- <property name="maven.build.dir" value="target"/>
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
- <property name="maven.build.srcDir.0" value="src/main/clojure"/>
-
- <!-- clean -->
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}"/>
- </target>
-
- <!-- build -->
- <target name="build" description="Copy the files">
- <mkdir dir="${maven.build.outputDir}"/>
- <copy todir="${maven.build.outputDir}">
- <fileset dir="${maven.build.srcDir.0}"/>
- </copy>
- </target>
-
- <!-- package -->
- <target name="package" depends="build" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html"/>
- </target>
-
- <!-- jar -->
- <target name="jar" depends="package" description="Builds the jar for the application"/>
-</project>
diff --git a/dev-java/core-specs-alpha/metadata.xml b/dev-java/core-specs-alpha/metadata.xml
deleted file mode 100644
index 76ec8e09ecae..000000000000
--- a/dev-java/core-specs-alpha/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person" proxied="yes">
- <email>tgbugs@gmail.com</email>
- <name>Tom Gillespie</name>
- </maintainer>
- <maintainer type="project" proxied="proxy">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <upstream>
- <remote-id type="github">clojure/core.specs.alpha</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 4be765b60db4..0b45ed3496d2 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -288,12 +288,6 @@ acct-group/jabber
# Commands trigger an assertion and crashes, bug #892487
=sys-fs/lvm2-2.03.18
-# Florian Schmaus <flow@gentoo.org> (2023-01-27)
-# Previous dependencies of dev-lang/clojure, now part of the clojure
-# ebuild and no longer needed.
-# Removal on 2023-02-27.
-dev-java/core-specs-alpha
-
# Michał Górny <mgorny@gentoo.org> (2023-01-26)
# Unmaintained. Last release in 2003. The package fails to install
# since Aug 2021 and while a fix would be trivial, there does not seem