summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-30 07:14:12 +0000
committerSam James <sam@gentoo.org>2022-12-30 07:31:52 +0000
commit10f551c95f41eb63e1df49c72932fa3cbba80c04 (patch)
tree52260572cabf8852192f03b0cb3317c379dcee96
parentwww-client/lynx: add 2.9.0_pre11 (diff)
downloadgentoo-10f551c9.tar.gz
gentoo-10f551c9.tar.bz2
gentoo-10f551c9.zip
dev-util/dialog: add 1.3.20221229
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/dialog/Manifest2
-rw-r--r--dev-util/dialog/dialog-1.3.20221229.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-util/dialog/Manifest b/dev-util/dialog/Manifest
index a80e33ca760a..5906b053a7a5 100644
--- a/dev-util/dialog/Manifest
+++ b/dev-util/dialog/Manifest
@@ -1,2 +1,4 @@
DIST dialog-1.3-20220728.tgz 568086 BLAKE2B 086d946f2a8d298f1d26a193b5e99c00991a7f25fb032efef77109b20deaf08d54562673132bfa458d0c28360b2271e7ec50611ebe00e0c1584f178c0d8d7254 SHA512 dddceaf00bfec4b53f2cf67e51d4c54841d9db337536657c21bc8f324a0eb9c6d621f00e09bfb741bd263f171dde38cfea87568f86daf04a9e88575a0ed61218
DIST dialog-1.3-20220728.tgz.asc 729 BLAKE2B c317713cae1abe26471c005f033a8ebb406a2a741d67865f90c8a356e204b468fda1349247dbe42e84d434434d202938b55321a22ad0e048eedca93f59a7b547 SHA512 fe0e3559c1c6cbd6ac24cd5da96cde4e4780c6a804f1ed3c96c1ee93dc8f434336cb5cf27c9ac420338c8491dfa9beead48761f07152b2cae9f2d2f7d482eb8b
+DIST dialog-1.3-20221229.tgz 567965 BLAKE2B a027b4427ba2e4a2cfb7e66122a81ed3e3cd5b3ce3acfa250ce42a3464d4b015a8c7633b1d2160f915c54d8449097d19d33cd2f968bfef2a415fb42488bfa07b SHA512 920f22bc1565b3c936c95af6fe83dc1460dd81eb5d83bb8f43fd4f2b12cb9e37328b5ae32fb528fbe2ff2f4172935773022a3e6de455b8edfc0c8e37d5d02c26
+DIST dialog-1.3-20221229.tgz.asc 729 BLAKE2B bf9703905e16af1af11e68c5e0288e03ab2a72e7c16de80ec4bf830982020e28514674640f42e0fc77ae1861d3f527990279a2e65a7aef6f78b3076b245df149 SHA512 b4d2dd6ab6e4f792a0156508bdec8516a927d50e1e65208e1fb155a618321addc71e0c35658b8da9a2166c4401acc3ec47e050acdb84fd768c8cc089ff30c41a
diff --git a/dev-util/dialog/dialog-1.3.20221229.ebuild b/dev-util/dialog/dialog-1.3.20221229.ebuild
new file mode 100644
index 000000000000..0beb06989f2f
--- /dev/null
+++ b/dev-util/dialog/dialog-1.3.20221229.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P=${PN}-$(ver_rs 2 -)
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/thomasdickey.asc
+inherit verify-sig
+
+DESCRIPTION="Tool to display dialog boxes from a shell"
+HOMEPAGE="https://invisible-island.net/dialog/"
+SRC_URI="https://invisible-island.net/archives/dialog/${MY_P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/dialog/${MY_P}.tgz.asc )"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0/15"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples minimal nls unicode"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r5:=[unicode(+)?]"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ "
+BDEPEND="
+ virtual/pkgconfig
+ !minimal? ( sys-devel/libtool )
+ verify-sig? ( sec-keys/openpgp-keys-thomasdickey )
+"
+
+src_prepare() {
+ default
+
+ sed -i -e '/LIB_CREATE=/s:${CC}:& ${LDFLAGS}:g' configure || die
+ sed -i '/$(LIBTOOL_COMPILE)/s:$: $(LIBTOOL_OPTS):' makefile.in || die
+}
+
+src_configure() {
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ export ac_cv_prog_LIBTOOL=glibtool
+ fi
+
+ econf \
+ --disable-rpath-hack \
+ --with-pkg-config \
+ $(use_enable nls) \
+ $(use_with !minimal libtool) \
+ --with-libtool-opts='-shared' \
+ --with-ncurses$(usex unicode w '')
+}
+
+src_install() {
+ use minimal && default || emake DESTDIR="${D}" install-full
+
+ use examples && dodoc -r samples
+
+ dodoc CHANGES README
+
+ find "${ED}" -name '*.la' -delete || die
+}