summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-01 16:27:44 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-01 17:05:19 +0100
commit10fa0b6c99937f7e3a945147a99f6b8de4821036 (patch)
tree4f7e0e14643d2a2e718030fb52c0a42235439c8f
parentdev-python/zstandard: Bump to 0.22.0 (diff)
downloadgentoo-10fa0b6c99937f7e3a945147a99f6b8de4821036.tar.gz
gentoo-10fa0b6c99937f7e3a945147a99f6b8de4821036.tar.bz2
gentoo-10fa0b6c99937f7e3a945147a99f6b8de4821036.zip
dev-python/wtforms: Bump to 3.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/wtforms/Manifest1
-rw-r--r--dev-python/wtforms/wtforms-3.1.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/wtforms/Manifest b/dev-python/wtforms/Manifest
index 51e196500c14..902e6688109f 100644
--- a/dev-python/wtforms/Manifest
+++ b/dev-python/wtforms/Manifest
@@ -1,2 +1,3 @@
DIST WTForms-3.0.1.tar.gz 137513 BLAKE2B 17fbb385a28baefaf3fe368b7c7dbd3d6671aaef887ee89617e60e0537ae060248442d4990e7ea926b15d4b85585a1c80ffb61c0fdad2627e5cca90799eb01d7 SHA512 a6db54a7ef9bc96b8fdf69cd65d3810fab9436ff9c056e1cfc580f5ecd0ed8837dcbb7c2adf92419cc5f74e865bb3a023e316407a87d5c5277da5d30e6836fb3
DIST wtforms-3.1.0.tar.gz 134500 BLAKE2B a88f29eb600b50f7de964d9cef1dd195f7731312bf291b3cbfa1664537c4eb242a59d435994c007c2e84eaf19942db5316e58154639bdd8ebee85d336ca5a9dc SHA512 6afc9bb2980668c753887945692525a4039e7a06fb3f0e2b56d1a60c382f099e1b75d722f19786ec0f32a1043b4909b1be28c8aeccadc4745785414835aebf02
+DIST wtforms-3.1.1.tar.gz 134343 BLAKE2B 935e1d0d881573f7fe0cf0099069f49c6f315007755ea27134c8d7db407880f3d5b5e1a427df588aaf427de4e8f09455a09d5c82e666d0fac4055558e3d49e4e SHA512 e7aec26103bf5069cc97474361b4f5788d41181a2560032b8072dc62b29824830b739ddf9df60710685293eec5173d8c44c5fbeee8487f01180a08970abb6c77
diff --git a/dev-python/wtforms/wtforms-3.1.1.ebuild b/dev-python/wtforms/wtforms-3.1.1.ebuild
new file mode 100644
index 000000000000..718aeb1fb598
--- /dev/null
+++ b/dev-python/wtforms/wtforms-3.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYPI_PN="WTForms"
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Flexible forms validation and rendering library for python web development"
+HOMEPAGE="
+ https://wtforms.readthedocs.io/
+ https://github.com/wtforms/wtforms/
+ https://pypi.org/project/WTForms/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/email-validator[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest