summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-24 14:42:03 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-24 14:42:03 +0200
commit1105a5fade1ee6f82065372eb14bbaca17e2043b (patch)
treeac0a02c4418cac7dfc13ec7c44d11ee882bbd3b4
parentdev-python/aws-sam-translator: Remove old (diff)
downloadgentoo-1105a5fade1ee6f82065372eb14bbaca17e2043b.tar.gz
gentoo-1105a5fade1ee6f82065372eb14bbaca17e2043b.tar.bz2
gentoo-1105a5fade1ee6f82065372eb14bbaca17e2043b.zip
dev-python/python-lzo: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-lzo/Manifest1
-rw-r--r--dev-python/python-lzo/files/python-lzo-1.14-pytest.patch71
-rw-r--r--dev-python/python-lzo/python-lzo-1.14-r1.ebuild34
3 files changed, 0 insertions, 106 deletions
diff --git a/dev-python/python-lzo/Manifest b/dev-python/python-lzo/Manifest
index f014db482b3f..e2ce4ab8c4b5 100644
--- a/dev-python/python-lzo/Manifest
+++ b/dev-python/python-lzo/Manifest
@@ -1,2 +1 @@
-DIST python-lzo-1.14.tar.gz 14050 BLAKE2B e1df6b842562064ca13ddbacb194047ca343694d480a5a65e7d2876ec98a4215b4badb3b2a839f308dea8624c162a0536f363c093bcb2e5b48c68b69fb472729 SHA512 036cf7199afe12cec8b9c7ee92134f58357e1f892870ade3a619541a69c9cc92155892d53bd43330732b848016c2997e096a9a492e52f15d04fa516ca7645b93
DIST python-lzo-1.15.tar.gz 17633 BLAKE2B 577c78feeced5fba833c27b212b621a4cd8c9d4fe2dfb44d93cfd2b0aa9e88ee66926ec47d129b75496936f55d65e99e816d00e110b1d70300639a3907d823fd SHA512 1c7889f01b4809e7023804b702ac35a59e45df735865ff50449c69b414966c9f928c254ef7dde9e28fcc44ba4ac12df220bd6a6d34c0d274123f59c65ce3c5fe
diff --git a/dev-python/python-lzo/files/python-lzo-1.14-pytest.patch b/dev-python/python-lzo/files/python-lzo-1.14-pytest.patch
deleted file mode 100644
index 2abaab19aab5..000000000000
--- a/dev-python/python-lzo/files/python-lzo-1.14-pytest.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-https://github.com/jd-boyd/python-lzo/pull/66
-
-diff --git a/setup.py b/setup.py
-index 033692d..e7e383d 100644
---- a/setup.py
-+++ b/setup.py
-@@ -33,7 +33,7 @@ class TestCommand(Command):
- raise SystemExit(
- subprocess.call([sys.executable,
- '-m',
-- 'nose']))
-+ 'pytest']))
-
-
- if sys.platform == "win32":
-@@ -91,7 +91,7 @@ setup_args = get_kw(
- maintainer_email="jdboyd@jdboyd.net",
- url="https://github.com/jd-boyd/python-lzo",
- license="GNU General Public License (GPL)",
-- tests_require=['nose'],
-+ tests_require=['pytest'],
- cmdclass={
- 'test': TestCommand
- },
-diff --git a/tests/test.py b/tests/test_lzo.py
-similarity index 88%
-rename from tests/test.py
-rename to tests/test_lzo.py
-index af761d9..b9d5c88 100644
---- a/tests/test.py
-+++ b/tests/test_lzo.py
-@@ -32,6 +32,7 @@
-
- from __future__ import print_function
-
-+import pytest
- import sys, string
-
- # update sys.path when running in the build directory
-@@ -94,22 +95,20 @@ def test_version():
- assert pkg_version == mod_version, \
- "%r != %r" %(pkg_version, mod_version)
-
--def test_lzo():
-- yield gen, b"aaaaaaaaaaaaaaaaaaaaaaaa"
-- yield gen, b"abcabcabcabcabcabcabcabc"
-- yield gen, b"abcabcabcabcabcabcabcabc", 9
-+@pytest.mark.parametrize("src, level", [(b"aaaaaaaaaaaaaaaaaaaaaaaa", 1), (b"abcabcabcabcabcabcabcabc", 1), (b"abcabcabcabcabcabcabcabc", 9)])
-+def test_lzo(src, level):
-+ gen(src, level)
-
--
--def test_lzo_raw():
-- yield gen_raw, b"aaaaaaaaaaaaaaaaaaaaaaaa"
-- yield gen_raw, b"abcabcabcabcabcabcabcabc"
-- yield gen_raw, b"abcabcabcabcabcabcabcabc", 9
-+@pytest.mark.parametrize("src, level", [(b"aaaaaaaaaaaaaaaaaaaaaaaa", 1), (b"abcabcabcabcabcabcabcabc", 1), (b"abcabcabcabcabcabcabcabc", 9)])
-+def test_lzo_raw(src, level):
-+ gen_raw(src, level)
-
-
- def test_lzo_empty():
-- yield gen, b""
-- yield gen_raw, b""
-+ gen(b"")
-
-+def test_lzo_empty_raw():
-+ gen_raw(b"")
-
- def test_lzo_big():
- gen(b" " * 131072)
diff --git a/dev-python/python-lzo/python-lzo-1.14-r1.ebuild b/dev-python/python-lzo/python-lzo-1.14-r1.ebuild
deleted file mode 100644
index c26a43f314d0..000000000000
--- a/dev-python/python-lzo/python-lzo-1.14-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 prefix pypi
-
-DESCRIPTION="Python interface to lzo"
-HOMEPAGE="https://github.com/jd-boyd/python-lzo"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~riscv x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="dev-libs/lzo:2"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-pytest.patch
-)
-
-# We can't use pytest at the moment because the package uses "yield tests"
-# https://docs.pytest.org/en/6.2.x/deprecations.html#yield-tests
-distutils_enable_tests pytest
-
-python_prepare_all() {
- hprefixify setup.py
- distutils-r1_python_prepare_all
-}