summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-29 15:03:44 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-29 20:56:11 +0100
commit110a565b9a8bcd4a0af92d97ef43921ebe91a8e5 (patch)
treeaf5f5f13137a3fbce74cc268b6bc979c2c5a1c43
parentsys-libs/libomp: Bump to 15.0.6 (diff)
downloadgentoo-110a565b.tar.gz
gentoo-110a565b.tar.bz2
gentoo-110a565b.zip
sys-devel/clang-runtime: Bump to 15.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-devel/clang-runtime/clang-runtime-15.0.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-15.0.6.ebuild b/sys-devel/clang-runtime/clang-runtime-15.0.6.ebuild
new file mode 100644
index 000000000000..f0ec98510540
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-15.0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )
+"