summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-31 12:12:59 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-31 12:12:59 +0200
commit110e4b0a41fef16ca9d00f0f1b8833a5cf883077 (patch)
treea4f4eacaffe0a692f8704d12b96b327ff4ded934
parentdev-python/tblib: Enable py3.12 (diff)
downloadgentoo-110e4b0a41fef16ca9d00f0f1b8833a5cf883077.tar.gz
gentoo-110e4b0a41fef16ca9d00f0f1b8833a5cf883077.tar.bz2
gentoo-110e4b0a41fef16ca9d00f0f1b8833a5cf883077.zip
dev-python/stdio-mgr: Modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/stdio-mgr/Manifest1
-rw-r--r--dev-python/stdio-mgr/stdio-mgr-1.0.1-r1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/stdio-mgr/Manifest b/dev-python/stdio-mgr/Manifest
index 59da72d82f9b..938131f9cd59 100644
--- a/dev-python/stdio-mgr/Manifest
+++ b/dev-python/stdio-mgr/Manifest
@@ -1 +1,2 @@
+DIST stdio-mgr-1.0.1.gh.tar.gz 8447 BLAKE2B 72038ea34177829d77ac239585775557b5a0a253879c027b2aad64045ec8bafbfdc250d94fe61cde96f06616f774edf42b384bfef7fbf69af442b0a9b703cf9a SHA512 2d18e5d65faa7a73373b56fdac3893768a65a36bed17f017b647e71431a6bff44ce1d39022f1dbbd31ddc9c0e704743a164f4b7610fb62d75aa34ecb53331366
DIST stdio-mgr-1.0.1.tar.gz 8447 BLAKE2B 72038ea34177829d77ac239585775557b5a0a253879c027b2aad64045ec8bafbfdc250d94fe61cde96f06616f774edf42b384bfef7fbf69af442b0a9b703cf9a SHA512 2d18e5d65faa7a73373b56fdac3893768a65a36bed17f017b647e71431a6bff44ce1d39022f1dbbd31ddc9c0e704743a164f4b7610fb62d75aa34ecb53331366
diff --git a/dev-python/stdio-mgr/stdio-mgr-1.0.1-r1.ebuild b/dev-python/stdio-mgr/stdio-mgr-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..8c5d589995c3
--- /dev/null
+++ b/dev-python/stdio-mgr/stdio-mgr-1.0.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Context manager for mocking/wrapping stdin/stdout/stderr"
+HOMEPAGE="
+ https://github.com/bskinn/stdio-mgr/
+ https://pypi.org/project/stdio-mgr/
+"
+SRC_URI="
+ https://github.com/bskinn/stdio-mgr/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/attrs-17.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+# doc directory is not included in the release tarball for some reason
+#distutils_enable_sphinx doc \
+# dev-python/sphinxcontrib-programoutput \
+# dev-python/sphinx-rtd-theme
+
+python_test() {
+ # skip the doctests
+ epytest tests
+}