summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-26 23:21:07 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-26 21:33:10 +0200
commit11122d424ed9dbb56a81dbc339cbb8d8be445e9a (patch)
tree7ae88bf93a67ba2b9a1b9dd75899b870e66261c1
parentnet-analyzer/suricata: [QA] Use standard meaning of USE=luajit (diff)
downloadgentoo-11122d424ed9dbb56a81dbc339cbb8d8be445e9a.tar.gz
gentoo-11122d424ed9dbb56a81dbc339cbb8d8be445e9a.tar.bz2
gentoo-11122d424ed9dbb56a81dbc339cbb8d8be445e9a.zip
net-dns/pdns: [QA] Use standard meaning of USE=luajit
Fix the package to use standard meaning for USE=luajit instead of making it exclusive with USE=lua.
-rw-r--r--net-dns/pdns/metadata.xml1
-rw-r--r--net-dns/pdns/pdns-4.0.5.ebuild12
-rw-r--r--net-dns/pdns/pdns-4.1.0.ebuild12
-rw-r--r--net-dns/pdns/pdns-4.1.1.ebuild12
4 files changed, 21 insertions, 16 deletions
diff --git a/net-dns/pdns/metadata.xml b/net-dns/pdns/metadata.xml
index 36c754fdabc7..57e0d147b337 100644
--- a/net-dns/pdns/metadata.xml
+++ b/net-dns/pdns/metadata.xml
@@ -12,7 +12,6 @@ standards documents. Furthermore, PowerDNS interfaces with almost any database.
</longdescription>
<use>
<flag name="botan">Make it possible to use the <pkg>dev-libs/botan</pkg> library for crypto-related stuff (like DNSSec) which can be significantly faster than PolarSSL.</flag>
- <flag name="luajit">Enable support for <pkg>dev-lang/luajit</pkg></flag>
<flag name="mydns">Making it possible to use a MyDNS MySQL database with PowerDNS (not recommended for new deployments).</flag>
<flag name="opendbx">Use a database supported by <pkg>dev-db/opendbx</pkg> as backend.</flag>
<flag name="protobuf">Enable support for <pkg>dev-libs/protobuf</pkg>.</flag>
diff --git a/net-dns/pdns/pdns-4.0.5.ebuild b/net-dns/pdns/pdns-4.0.5.ebuild
index 90ac1b5b3306..bd6f0e93330f 100644
--- a/net-dns/pdns/pdns-4.0.5.ebuild
+++ b/net-dns/pdns/pdns-4.0.5.ebuild
@@ -20,15 +20,17 @@ KEYWORDS="amd64 x86"
IUSE="botan debug doc geoip ldap libressl lua luajit mydns mysql opendbx postgres protobuf remote sqlite systemd tools tinydns test"
-REQUIRED_USE="mydns? ( mysql ) ?? ( lua luajit )"
+REQUIRED_USE="mydns? ( mysql )"
RDEPEND="
libressl? ( dev-libs/libressl:= )
!libressl? ( dev-libs/openssl:= )
>=dev-libs/boost-1.35:=
botan? ( dev-libs/botan:2= )
- lua? ( dev-lang/lua:= )
- luajit? ( dev-lang/luajit:= )
+ lua? (
+ !luajit? ( dev-lang/lua:= )
+ luajit? ( dev-lang/luajit:= )
+ )
mysql? ( virtual/mysql )
postgres? ( dev-db/postgresql:= )
ldap? ( >=net-nds/openldap-2.0.27-r4 )
@@ -74,8 +76,8 @@ src_configure() {
$(use_enable test unit-tests) \
$(use_enable tools) \
$(use_enable systemd) \
- $(use_with lua) \
- $(use_with luajit) \
+ $(usex lua "$(use_with !luajit lua) $(use_with luajit)" \
+ '--without-lua --without-luajit') \
$(use_with protobuf) \
${myconf}
}
diff --git a/net-dns/pdns/pdns-4.1.0.ebuild b/net-dns/pdns/pdns-4.1.0.ebuild
index 476a969f8a9a..60d5320f505e 100644
--- a/net-dns/pdns/pdns-4.1.0.ebuild
+++ b/net-dns/pdns/pdns-4.1.0.ebuild
@@ -20,15 +20,17 @@ KEYWORDS="~amd64 ~x86"
IUSE="botan debug doc geoip ldap libressl lua luajit mydns mysql opendbx postgres protobuf remote sodium sqlite systemd tools tinydns test"
-REQUIRED_USE="mydns? ( mysql ) ?? ( lua luajit )"
+REQUIRED_USE="mydns? ( mysql )"
RDEPEND="
libressl? ( dev-libs/libressl:= )
!libressl? ( dev-libs/openssl:= )
>=dev-libs/boost-1.35:=
botan? ( dev-libs/botan:2= )
- lua? ( dev-lang/lua:= )
- luajit? ( dev-lang/luajit:= )
+ lua? (
+ !luajit? ( dev-lang/lua:= )
+ luajit? ( dev-lang/luajit:= )
+ )
mysql? ( virtual/mysql )
postgres? ( dev-db/postgresql:= )
ldap? ( >=net-nds/openldap-2.0.27-r4 app-crypt/mit-krb5 )
@@ -74,8 +76,8 @@ src_configure() {
$(use_enable tools) \
$(use_enable systemd) \
$(use_enable sodium libsodium) \
- $(use_with lua) \
- $(use_with luajit) \
+ $(usex lua "$(use_with !luajit lua) $(use_with luajit)" \
+ '--without-lua --without-luajit') \
$(use_with protobuf) \
${myconf}
}
diff --git a/net-dns/pdns/pdns-4.1.1.ebuild b/net-dns/pdns/pdns-4.1.1.ebuild
index 7ec5508cb26b..1dd30fc18958 100644
--- a/net-dns/pdns/pdns-4.1.1.ebuild
+++ b/net-dns/pdns/pdns-4.1.1.ebuild
@@ -20,15 +20,17 @@ KEYWORDS="~amd64 ~x86"
IUSE="botan debug doc geoip ldap libressl lua luajit mydns mysql opendbx postgres protobuf remote sodium sqlite systemd tools tinydns test"
-REQUIRED_USE="mydns? ( mysql ) ?? ( lua luajit )"
+REQUIRED_USE="mydns? ( mysql )"
RDEPEND="
libressl? ( dev-libs/libressl:= )
!libressl? ( dev-libs/openssl:= )
>=dev-libs/boost-1.35:=
botan? ( dev-libs/botan:2= )
- lua? ( dev-lang/lua:= )
- luajit? ( dev-lang/luajit:= )
+ lua? (
+ !luajit? ( dev-lang/lua:= )
+ luajit? ( dev-lang/luajit:= )
+ )
mysql? ( virtual/mysql )
postgres? ( dev-db/postgresql:= )
ldap? ( >=net-nds/openldap-2.0.27-r4 app-crypt/mit-krb5 )
@@ -74,8 +76,8 @@ src_configure() {
$(use_enable tools) \
$(use_enable systemd) \
$(use_enable sodium libsodium) \
- $(use_with lua) \
- $(use_with luajit) \
+ $(usex lua "$(use_with !luajit lua) $(use_with luajit)" \
+ '--without-lua --without-luajit') \
$(use_with protobuf) \
${myconf}
}