summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2019-11-16 10:55:02 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-16 10:55:02 -0800
commit112c7bcb97f9588b08a6a5028b352e05f07701cf (patch)
tree5799c523cba4a7adbba7d3142478df2bf8fe66ed
parentdev-python/sphinx-issues: New package, dependency for jinja[doc] (diff)
downloadgentoo-112c7bcb.tar.gz
gentoo-112c7bcb.tar.bz2
gentoo-112c7bcb.zip
dev-python/jinja: Revbump to 2.10.3-r1, fix USE=doc add python3_8
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/jinja/jinja-2.10.3-r1.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/jinja/jinja-2.10.3-r1.ebuild b/dev-python/jinja/jinja-2.10.3-r1.ebuild
new file mode 100644
index 000000000000..39131f10d5a9
--- /dev/null
+++ b/dev-python/jinja/jinja-2.10.3-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A full-featured template engine for Python"
+HOMEPAGE="http://jinja.pocoo.org/ https://pypi.org/project/Jinja2/"
+
+# pypi tarball is missing tests
+SRC_URI="https://github.com/pallets/jinja/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ !dev-python/jinja:compat"
+RDEPEND="${CDEPEND}
+ dev-python/markupsafe[${PYTHON_USEDEP}]"
+BDEPEND="${CDEPEND}
+ doc? (
+ dev-python/sphinx
+ dev-python/sphinx-issues
+ dev-python/pallets-sphinx-themes
+ )"
+
+distutils_enable_tests pytest
+
+# XXX: handle Babel better?
+
+wrap_opts() {
+ local mydistutilsargs=()
+
+ if [[ ${EPYTHON} == python* ]]; then
+ mydistutilargs+=( --with-debugsupport )
+ fi
+
+ "${@}"
+}
+
+src_prepare() {
+ # avoid unnecessary dep on extra sphinxcontrib modules
+ sed -i '/sphinxcontrib.log_cabinet/ d' docs/conf.py || die
+ printf "############################# SED ###############################\n"
+
+ distutils-r1_src_prepare
+}
+
+python_prepare() {
+ # async is not supported on python2
+ if ! python_is_python3; then
+ rm -f jinja2/async*.py || die "Failed to remove async from python2"
+ fi
+}
+
+python_compile() {
+ wrap_opts distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+
+ insinto /usr/share/vim/vimfiles/syntax
+ doins ext/Vim/*
+}
+
+pkg_postinst() {
+ if ! has_version dev-python/Babel; then
+ elog "For i18n support, please emerge dev-python/Babel."
+ fi
+}