summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2020-10-22 10:45:02 +0200
committerSam James <sam@gentoo.org>2020-10-22 11:38:12 +0000
commit115044510a34dbe0dc9b4ea1ec1e75083e4a8f5e (patch)
tree4c01f11c91b7fd165b50814da11b8b46014c3530
parentapp-text/diff-pdf: bump to 0.4.1 (diff)
downloadgentoo-115044510a34dbe0dc9b4ea1ec1e75083e4a8f5e.tar.gz
gentoo-115044510a34dbe0dc9b4ea1ec1e75083e4a8f5e.tar.bz2
gentoo-115044510a34dbe0dc9b4ea1ec1e75083e4a8f5e.zip
net-misc/unison: bump to 2.51.3
Closes: https://bugs.gentoo.org/750449 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/unison/Manifest1
-rw-r--r--net-misc/unison/unison-2.51.3.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/net-misc/unison/Manifest b/net-misc/unison/Manifest
index e2922b5d259e..4afe614f4591 100644
--- a/net-misc/unison/Manifest
+++ b/net-misc/unison/Manifest
@@ -4,4 +4,5 @@ DIST unison-2.48.4-manual.pdf 516093 BLAKE2B 8e752a01b8c4335d6687b1f4f20ee09fda9
DIST unison-2.51.2-manual.html 311981 BLAKE2B 1e1bc18d5bca5d50976b28c4e59cc27fcc1ef4415514c6a8db4be02659c168949738cf2941f88cb949097c16e455bd3fb50aee0fdc6023d3d36d6821f74acd05 SHA512 2fc47e51ffde2e9176ca85d4d29fe0d254b539112d867782e9bb0f71ea74ad02892a88b6bfe59756268875f0d62abfb125406e4939671a0eb8a64696ba01b997
DIST unison-2.51.2-manual.pdf 518963 BLAKE2B 30d0010e7a11b10bb9fba3f5836e084452429f09a94cfcc639305d17ea69499eeeac1026a0bd35c785b08456d79b1b4c68c348c10237509c8cf4e45720d037e0 SHA512 170b280e5a9ad0fc4ed848aaa1c4a6a8977edfdcc133bf3288c03e1d4d6d20383cfa06593b9d149e746795945f6afb8d807cfa16f5cf8ab47795e3074776518d
DIST unison-2.51.2.tar.gz 691251 BLAKE2B 39f72e7229826ec1a2151b7d7af416d85ffe2f9e6f1277be77d2202088d41fa3aca45413b931e661d72b787710f7d3429352542554990bb638589d52f77fe43f SHA512 9ba24f8d46f3f8bf3c26ea1beb396e276a82a742d9e8479cb421ff9f97fa2051fc8fb809b5f47ebc88dcb6a04878e1bdeae8081540e35af710ccbdaead84c115
+DIST unison-2.51.3.tar.gz 1370060 BLAKE2B 3e082c5de8c68d87fd4d061dbcf535b9001bd3bacd740fede4e94a239bc554e463c0493260748df61527304d2f874cb194f629fb1f066a47be5a5e54360f3cb7 SHA512 202bc592cf18d3ac76d7e29ec71add5d6e33a96b4b885e0e2add9a5a621db2290184f268c70e4f05e4884d6cdfed09f6fcd3dde85681c39628a10ea552917c8f
DIST unison-2.51.3_rc3.tar.gz 1370077 BLAKE2B 4a894c8837112986b6bad20b0f3db7459fc861d90c094408b20ad70a2726ea0c7882e81126f939982b46625684c59233b55f6f6c30ca8724b8a421b9250fc904 SHA512 988fa67fcbf46832e46295c12e3faeade6b6785f64b9ca55e7e2d877bccee0585b3b7865c61b4abbbd06100b2850ec3460d3016d2faa4dffd9c54383179709dc
diff --git a/net-misc/unison/unison-2.51.3.ebuild b/net-misc/unison/unison-2.51.3.ebuild
new file mode 100644
index 000000000000..8abdd80a5ad1
--- /dev/null
+++ b/net-misc/unison/unison-2.51.3.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg-utils
+
+DESCRIPTION="Two-way cross-platform file synchronizer"
+HOMEPAGE="https://www.seas.upenn.edu/~bcpierce/unison/"
+SRC_URI="https://github.com/bcpierce00/unison/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+# Not available for the rcs
+#SRC_URI+=" doc? (
+# https://www.seas.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.pdf
+# https://www.seas.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.html
+# )"
+
+LICENSE="GPL-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="debug gtk +ocamlopt threads"
+RESTRICT="!ocamlopt? ( strip )"
+
+# ocaml version so we are sure it has ocamlopt use flag
+BDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="gtk? ( dev-ml/lablgtk:2= )"
+RDEPEND="gtk? ( dev-ml/lablgtk:2=
+ || ( net-misc/x11-ssh-askpass net-misc/ssh-askpass-fullscreen ) )
+ >=app-eselect/eselect-unison-0.4"
+
+DOCS=( BUGS.txt CONTRIB INSTALL NEWS README ROADMAP.txt TODO.txt )
+
+src_compile() {
+ local myconf="all"
+
+ if use threads; then
+ myconf="$myconf THREADS=true"
+ fi
+
+ if use debug; then
+ myconf="$myconf DEBUGGING=true"
+ fi
+
+ if use gtk; then
+ myconf="$myconf UISTYLE=gtk2"
+ else
+ myconf="$myconf UISTYLE=text"
+ fi
+
+ use ocamlopt || myconf="$myconf NATIVE=false"
+
+ # Discard cflags as it will try to pass them to ocamlc...
+ emake $myconf CFLAGS=""
+}
+
+src_test() {
+ emake test CFLAGS=""
+}
+
+src_install() {
+ # install manually, since it's just too much
+ # work to force the Makefile to do the right thing.
+ local binname
+ cd src || die
+ for binname in unison unison-fsmonitor; do
+ newbin ${binname} ${binname}-${SLOT}
+ done
+
+ if use gtk; then
+ newicon -s scalable ../icons/U.svg ${PN}-${SLOT}.svg
+ make_desktop_entry unison-${SLOT} "${PN} (${SLOT})" "${EPREFIX}/usr/share/icons/hicolor/scalable/apps/${PN}-${SLOT}.svg"
+ fi
+
+ # No docs for release candidates
+ #if use doc; then
+ # DOCS+=( "${DISTDIR}/${P}-manual.pdf" )
+ # HTML_DOCS=( "${DISTDIR}/${P}-manual.html" )
+ #fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "Unison now uses SLOTs, so you can specify servercmd=/usr/bin/unison-${SLOT}"
+ elog "in your profile files to access exactly this version over ssh."
+ elog "Or you can use 'eselect unison' to set the version."
+ eselect unison update || die
+
+ if use gtk; then
+ xdg_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk; then
+ xdg_icon_cache_update
+ fi
+}