summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-27 21:04:36 +0000
committerSam James <sam@gentoo.org>2021-02-27 21:06:56 +0000
commit11513801b446176a786aa88dda69addf8c47a7e3 (patch)
tree97bdf5040b95141eb701fcff0f332423417e5fa0
parentmail-client/alot: add Python 3.9 (diff)
downloadgentoo-11513801.tar.gz
gentoo-11513801.tar.bz2
gentoo-11513801.zip
dev-python/pipenv: add Python 3.9
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/pipenv/pipenv-2020.11.15.ebuild10
-rw-r--r--dev-python/pipenv/pipenv-2020.11.4.ebuild9
2 files changed, 10 insertions, 9 deletions
diff --git a/dev-python/pipenv/pipenv-2020.11.15.ebuild b/dev-python/pipenv/pipenv-2020.11.15.ebuild
index e20e61223c3f..9028b19d5c26 100644
--- a/dev-python/pipenv/pipenv-2020.11.15.ebuild
+++ b/dev-python/pipenv/pipenv-2020.11.15.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_7 python3_8 )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
@@ -26,8 +26,7 @@ RDEPEND="
dev-python/pip[${PYTHON_USEDEP}]
>=dev-python/virtualenv-20.0.35[${PYTHON_USEDEP}]
dev-python/virtualenv-clone[${PYTHON_USEDEP}]
- "
-
+"
BDEPEND="
${RDEPEND}
test? (
@@ -35,7 +34,8 @@ BDEPEND="
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
- )"
+ )
+"
src_prepare() {
# remove vendored version of PyYAML that is backported to Python2
diff --git a/dev-python/pipenv/pipenv-2020.11.4.ebuild b/dev-python/pipenv/pipenv-2020.11.4.ebuild
index f9e44ff1d377..8f561656bd1f 100644
--- a/dev-python/pipenv/pipenv-2020.11.4.ebuild
+++ b/dev-python/pipenv/pipenv-2020.11.4.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_7 python3_8 )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
@@ -26,7 +26,7 @@ RDEPEND="
dev-python/pip[${PYTHON_USEDEP}]
>=dev-python/virtualenv-20.0.35[${PYTHON_USEDEP}]
dev-python/virtualenv-clone[${PYTHON_USEDEP}]
- "
+"
BDEPEND="
${RDEPEND}
@@ -35,7 +35,8 @@ BDEPEND="
dev-python/mock[${PYTHON_USEDEP}]
<dev-python/pytest-5[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
- )"
+ )
+"
src_prepare() {
# remove vendored version of PyYAML that is backported to Python2