summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-27 07:03:36 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-27 07:56:26 +0200
commit115b933e8ff96e55c3ece77382aad84e300ef7f1 (patch)
tree9832db1cb92277de5b1965ec00f99b34ce3b2359
parentdev-python/boto3: Bump to 1.28.55 (diff)
downloadgentoo-115b933e.tar.gz
gentoo-115b933e.tar.bz2
gentoo-115b933e.zip
app-admin/awscli: Bump to 1.29.55
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.29.55.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 132b766e2f81..df061ab3eb5e 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,3 +1,4 @@
DIST aws-cli-1.29.49.gh.tar.gz 2533689 BLAKE2B 0ead02f739adc66eed988bedf41b9b508c553a6dfcea07af022a5b3098e8a3f65e4fc59e512b3374b3f1fcf89ba30f0dcca20e2cd6638c2d2b37b09646f1f4ca SHA512 336e012105d295dc69734fbd9f47a9cb6f2a54fc4dfac388e52e24519967e0aab5e3d98920f8ad05ea242e39673b6a8f98bb9af551507ee0560ee7598c9f86ec
DIST aws-cli-1.29.53.gh.tar.gz 2549518 BLAKE2B 4c9932ddbfb5f8619006589c0ed8f00b5d0230bc9d7fa811875cc4b16e9b5583a3abe4ccbb290524565dde2f78ae5696162863ea6e5224517c98414d7cb74344 SHA512 1150c20f5cc3da3a0ba2e25741441a7db8b6e399a927366902b30fd30a394634d015cc6b53bbfe7bcb759ce0aec6e0f9432a23e5b8d00cd9c2bb71afd5744627
DIST aws-cli-1.29.54.gh.tar.gz 2550145 BLAKE2B 75c11a59218e4b0def9313f342c076c0cf414744f0f68e7b4a3e80800dabb95ce184207a6bb7167a85fba829510da72875beeee97506911987b9efff0b58d5d7 SHA512 2dfe1a41cb2235c67fba78e1f83d406ccc9db9b3965b88d7ca4fd31c584fa82b373e818c93b81c4fdb56583ec7a500e6122dc4b9db70bb26cf703fe1827bd663
+DIST aws-cli-1.29.55.gh.tar.gz 2551493 BLAKE2B 79ea509819519d54c20068f6db7ba90aa9c43de83b1bf0ddad9d88e029b6a54f56c5f75a4aa30e5b29a5c84d5a7dd8ab7b07e0f451da67d96b440a25ea042df2 SHA512 32083c906650bf0e8dd6739220498d4c706cc3e844f7bbe1cf9934e25cfd0e85f349ebf56527366193d5a39af77afe030a8df77de1f49f3b75e110977d163873
diff --git a/app-admin/awscli/awscli-1.29.55.ebuild b/app-admin/awscli/awscli-1.29.55.ebuild
new file mode 100644
index 000000000000..39ad0f4a42cc
--- /dev/null
+++ b/app-admin/awscli/awscli-1.29.55.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.7.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken xdist (signal() works only in main thread)
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py::TestHelpPager::test_can_handle_ctrl_c
+ tests/unit/test_help.py::TestHelpPager::test_can_render_contents
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignore
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -p xdist -n "$(makeopts_jobs)"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}