summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-24 10:43:56 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-24 12:01:38 +0200
commit115d891375ad39a86db433d74056bc3f86065073 (patch)
tree6540fc27ac2d47e7089f0c1b80ef11b79e3363e6
parentnet-analyzer/tcpdump: Port to GLEP 81 'pcap' group/user (diff)
downloadgentoo-115d891375ad39a86db433d74056bc3f86065073.tar.gz
gentoo-115d891375ad39a86db433d74056bc3f86065073.tar.bz2
gentoo-115d891375ad39a86db433d74056bc3f86065073.zip
dev-python/aiohttp: Bump to 3.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/aiohttp/Manifest1
-rw-r--r--dev-python/aiohttp/aiohttp-3.7.0.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index 0d77d5957428..d802667b5d89 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -1 +1,2 @@
DIST aiohttp-3.6.2.tar.gz 1076923 BLAKE2B 14327a0bc5b5fffdf436a4c3525e4c25d80100aa464ed652316f7724c2bea6de4ace6c27e8a2a8cf9d895673ed63ed52e8c958ad611636e1e524a4e40efa4735 SHA512 49bd3089158c05ff6312420190ccd7fed95efb4a18b8aff7497d5507c71c692080d6949801edabdcd95379ca8e6614398408118d72ff1e782399e059e2cfc1a8
+DIST aiohttp-3.7.0.tar.gz 1112272 BLAKE2B 73dffecc54e47806a7827ca3f6a18cca2121cece368e691b6ba31495affc66c3a4ef67279f218c7972d4a7e71ac123a329d6b2e9ca22dc0afb3b7373d9ab0726 SHA512 97083c2cf294e7324aaa68c36b2e0e352e588b96cd6856308ce1303b5da2df3f3cabcdcde59dc108b6d70c068901dd14ad6a883ee9e25c6b00738e30e3d8f852
diff --git a/dev-python/aiohttp/aiohttp-3.7.0.ebuild b/dev-python/aiohttp/aiohttp-3.7.0.ebuild
new file mode 100644
index 000000000000..049055ec90aa
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-3.7.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="http client/server for asyncio"
+HOMEPAGE="https://pypi.org/project/aiohttp/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ >=dev-python/async_timeout-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/attrs-17.3.0[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/multidict-4.5.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.0[${PYTHON_USEDEP}]
+ dev-python/idna-ssl[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ ${COMMON_DEPEND}
+ !!dev-python/pytest-aiohttp
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ dev-python/brotlipy[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.4.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${COMMON_DEPEND}"
+
+DOCS=( CHANGES.rst CONTRIBUTORS.txt README.rst )
+
+distutils_enable_sphinx docs \
+ '>=dev-python/alabaster-0.6.2' \
+ 'dev-python/sphinxcontrib-asyncio' \
+ 'dev-python/sphinxcontrib-blockdiag' \
+ 'dev-python/sphinxcontrib-newsfeed' \
+ 'dev-python/sphinxcontrib-spelling' \
+ 'dev-python/sphinx' \
+ 'dev-python/sphinx-aiohttp-theme'
+
+distutils_enable_tests pytest || die "Tests fail with ${EPYTHON}"
+
+python_prepare_all() {
+ # Fails due to a warning
+ sed -e 's:test_read_boundary_with_incomplete_chunk:_&:' \
+ -i tests/test_multipart.py || die
+ # with py3.7+
+ sed -e 's:test_aiohttp_request_coroutine:_&:' \
+ -i tests/test_client_functional.py || die
+
+ # Fails due to path mismatch
+ sed -e 's:test_static:_&:' \
+ -i tests/test_route_def.py || die
+
+ # Internet
+ sed -e 's:test_mark_formdata_as_processed:_&:' \
+ -i tests/test_formdata.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pushd "${BUILD_DIR}/lib" >/dev/null || die
+ ln -snf "${S}"/{LICENSE.txt,tests} . || die
+ pytest -vv tests || die "Tests fail with ${EPYTHON}"
+ rm -rf .pytest_cache tests || die
+ popd >/dev/null || die
+}