summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-03 13:34:37 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-03 13:37:01 +0200
commit116b0a59726fdc7f9f7469c4d18735a929ecb89d (patch)
tree3bcc6a04e62b845f026c13796274c61dc5136bac
parentdev-util/catalyst: Stabilize 3.0.21 amd64, #849482 (diff)
downloadgentoo-116b0a59.tar.gz
gentoo-116b0a59.tar.bz2
gentoo-116b0a59.zip
dev-python/autobahn: Fix wrongly installing _trial_temp
Run tests from ${S} rather than the installed sitedir, so that _trial_temp ends up there rather than installed. Closes: https://bugs.gentoo.org/849470 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/autobahn/autobahn-22.3.2-r1.ebuild (renamed from dev-python/autobahn/autobahn-22.3.2.ebuild)5
-rw-r--r--dev-python/autobahn/autobahn-22.4.2.ebuild5
-rw-r--r--dev-python/autobahn/autobahn-22.5.1-r1.ebuild (renamed from dev-python/autobahn/autobahn-22.5.1.ebuild)5
3 files changed, 9 insertions, 6 deletions
diff --git a/dev-python/autobahn/autobahn-22.3.2.ebuild b/dev-python/autobahn/autobahn-22.3.2-r1.ebuild
index 6280c160e0bd..a372e795e614 100644
--- a/dev-python/autobahn/autobahn-22.3.2.ebuild
+++ b/dev-python/autobahn/autobahn-22.3.2-r1.ebuild
@@ -82,15 +82,16 @@ python_prepare_all() {
}
python_test() {
+ rm -rf autobahn || die
+
einfo "Testing all, cryptosign using twisted"
local -x USE_TWISTED=true
- cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
"${EPYTHON}" -m twisted.trial autobahn || die "Tests failed with ${EPYTHON}"
unset USE_TWISTED
einfo "RE-testing cryptosign and component_aio using asyncio"
local -x USE_ASYNCIO=true
- epytest autobahn/wamp/test/test_wamp_{cryptosign,component_aio}.py
+ epytest --pyargs autobahn.wamp.test.test_wamp_{cryptosign,component_aio}
unset USE_ASYNCIO
rm -f twisted/plugins/dropin.cache || die
diff --git a/dev-python/autobahn/autobahn-22.4.2.ebuild b/dev-python/autobahn/autobahn-22.4.2.ebuild
index 7bb27671fd5c..b7c800f34a87 100644
--- a/dev-python/autobahn/autobahn-22.4.2.ebuild
+++ b/dev-python/autobahn/autobahn-22.4.2.ebuild
@@ -83,15 +83,16 @@ python_prepare_all() {
}
python_test() {
+ rm -rf autobahn || die
+
einfo "Testing all, cryptosign using twisted"
local -x USE_TWISTED=true
- cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
"${EPYTHON}" -m twisted.trial autobahn || die "Tests failed with ${EPYTHON}"
unset USE_TWISTED
einfo "RE-testing cryptosign and component_aio using asyncio"
local -x USE_ASYNCIO=true
- epytest autobahn/wamp/test/test_wamp_{cryptosign,component_aio}.py
+ epytest --pyargs autobahn.wamp.test.test_wamp_{cryptosign,component_aio}
unset USE_ASYNCIO
rm -f twisted/plugins/dropin.cache || die
diff --git a/dev-python/autobahn/autobahn-22.5.1.ebuild b/dev-python/autobahn/autobahn-22.5.1-r1.ebuild
index f53a820194fa..b0aa9b524e50 100644
--- a/dev-python/autobahn/autobahn-22.5.1.ebuild
+++ b/dev-python/autobahn/autobahn-22.5.1-r1.ebuild
@@ -83,15 +83,16 @@ python_prepare_all() {
}
python_test() {
+ rm -rf autobahn || die
+
einfo "Testing all, cryptosign using twisted"
local -x USE_TWISTED=true
- cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
"${EPYTHON}" -m twisted.trial autobahn || die "Tests failed with ${EPYTHON}"
unset USE_TWISTED
einfo "RE-testing cryptosign and component_aio using asyncio"
local -x USE_ASYNCIO=true
- epytest autobahn/wamp/test/test_wamp_{cryptosign,component_aio}.py
+ epytest --pyargs autobahn.wamp.test.test_wamp_{cryptosign,component_aio}
unset USE_ASYNCIO
rm -f twisted/plugins/dropin.cache || die