summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-06-03 11:48:34 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-06-03 11:48:34 -0700
commit1184b81838b90078b6da1c8f42f72694bb4477de (patch)
treee3a5f2747268fe1e9d4422ad12029fc65f87aaed
parentdev-ada/xmlada: bump 2019 (diff)
downloadgentoo-1184b818.tar.gz
gentoo-1184b818.tar.bz2
gentoo-1184b818.zip
dev-lang/jsonnnet: Version bump to 0.13.0
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-lang/jsonnet/Manifest1
-rw-r--r--dev-lang/jsonnet/files/jsonnet-0.13.0-glibc-2.29.patch8
-rw-r--r--dev-lang/jsonnet/jsonnet-0.13.0.ebuild61
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-lang/jsonnet/Manifest b/dev-lang/jsonnet/Manifest
index ed4712918a99..dc57a4ec785d 100644
--- a/dev-lang/jsonnet/Manifest
+++ b/dev-lang/jsonnet/Manifest
@@ -1 +1,2 @@
DIST jsonnet-0.12.1.tar.gz 21839349 BLAKE2B 8601a35263003723b435d0075fe60f5301a49bddf63cdd55958df3eb7474569c28dbf54e0ba9d07fb6ade395af725193d1432b2c43fb2b271531af179e850df4 SHA512 25523dd19b4209a5ca39275ab3d3726b934442dd83a965ab0b79f0c67bd8ae85c438b2a63990b8eec921b137f908f946696be331b08cef92f15b6b8fa548cb0d
+DIST jsonnet-0.13.0.tar.gz 21850449 BLAKE2B fa0665d63b09dfc01a7454268d6edd467524cdfdb5d53e838665f046f1f08608c493503a88d7af7e26c3dc07e0ae4323753affab90c5ac41c27ebe8b7b39a4a0 SHA512 d19e5398763e37b79b0ef02368f6bd6215d2df234b5ff7a6d98e2306a0d47290600061c9f868c0c262570b4f0ee9eee6c309bcc93937b12f6c14f8d12339a7d5
diff --git a/dev-lang/jsonnet/files/jsonnet-0.13.0-glibc-2.29.patch b/dev-lang/jsonnet/files/jsonnet-0.13.0-glibc-2.29.patch
new file mode 100644
index 000000000000..f63a246fd882
--- /dev/null
+++ b/dev-lang/jsonnet/files/jsonnet-0.13.0-glibc-2.29.patch
@@ -0,0 +1,8 @@
+diff --git a/test_suite/error.import_folder.jsonnet.golden_regex b/test_suite/error.import_folder.jsonnet.golden_regex
+index bc468fb..c472b23 100644
+--- a/test_suite/error.import_folder.jsonnet.golden_regex
++++ b/test_suite/error.import_folder.jsonnet.golden_regex
+@@ -1,2 +1,2 @@
+-(STATIC ERROR: lib:1:1: unexpected end of file.|RUNTIME ERROR: couldn't open import "lib": basic_filebuf::underflow error reading the file(: iostream error)?
++(STATIC ERROR: lib:1:1: unexpected end of file.|RUNTIME ERROR: couldn't open import "lib": basic_filebuf::underflow error reading the file(: iostream error|: Is a directory)?
+ error.import_folder.jsonnet:17:1-13 )
diff --git a/dev-lang/jsonnet/jsonnet-0.13.0.ebuild b/dev-lang/jsonnet/jsonnet-0.13.0.ebuild
new file mode 100644
index 000000000000..bb16ecea1cd1
--- /dev/null
+++ b/dev-lang/jsonnet/jsonnet-0.13.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python3_6 python3_7 )
+
+inherit toolchain-funcs distutils-r1
+
+DESCRIPTION="A data templating language for app and tool developers "
+HOMEPAGE="https://jsonnet.org/"
+SRC_URI="https://github.com/google/jsonnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="python"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+DEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+BDEPEND="python? ( ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ "${FILESDIR}/jsonnet-0.12.1-makefile.patch"
+ "${FILESDIR}/jsonnet-0.12.1-dont-call-make-from-setuppy.patch"
+ "${FILESDIR}/jsonnet-0.13.0-glibc-2.29.patch"
+)
+
+src_prepare() {
+ default
+ use python && distutils-r1_src_prepare
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
+ jsonnet \
+ libjsonnet.so \
+ libjsonnet++.so
+
+ use python && distutils-r1_src_compile
+}
+
+src_test() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" test
+ use python && distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test || die
+}
+
+src_install() {
+ dolib.so libjsonnet*.so
+ dobin jsonnet
+
+ use python && distutils-r1_src_install
+}