summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-26 12:16:30 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-26 14:01:35 +0200
commit11a917ce209ddf77241fe29a4d5c41e0d7a80d12 (patch)
tree216d7ee4276b1b2b6617d6dfcfffcf37f2331093
parentdev-perl/CGI: Bump to version 4.500.0 (diff)
downloadgentoo-11a917ce.tar.gz
gentoo-11a917ce.tar.bz2
gentoo-11a917ce.zip
app-backup/luckybackup: 0.5.0 version bump, EAPI-7 bump
Closes: https://bugs.gentoo.org/674324 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-backup/luckybackup/Manifest1
-rw-r--r--app-backup/luckybackup/files/luckybackup-0.5.0-nomancompress.patch24
-rw-r--r--app-backup/luckybackup/luckybackup-0.5.0.ebuild54
3 files changed, 79 insertions, 0 deletions
diff --git a/app-backup/luckybackup/Manifest b/app-backup/luckybackup/Manifest
index a34f9450f5f3..65f1b17a9526 100644
--- a/app-backup/luckybackup/Manifest
+++ b/app-backup/luckybackup/Manifest
@@ -1 +1,2 @@
DIST luckybackup-0.4.9.tar.gz 5954338 BLAKE2B 632738f8c422ba7d56536fae866ce31d224910b41495e4df3be28a8013ba776e30b4d8e70ceb26c92d28aaf70c96402f27687c55d8f5d7aa5d405bab506a66be SHA512 86d6f1bd84f3bfd89734f0f2066cb17bbf9b4ede96167398de03a460c14d24bf4b50a91bb380655ace9a23497271e102b940ea99a7595cf17f596660dae7f7dd
+DIST luckybackup-0.5.0.tar.gz 5954426 BLAKE2B 7243db713b8e5a6f3929e6d011faff8bdef8b7580c328d336843c71e738fd92a0fd19b2bc3dd0a4695f0af6ec5b436b18833dc20c5ad3479036a1a0bca22be12 SHA512 41fe878a8008b291c2e6f5f8a77ae7dba9d2c547689e53a2dde15cbe733eefd7debf21b3570bd3414dace522ec7843f645639af2cca49b7c2f950eeac62b1f45
diff --git a/app-backup/luckybackup/files/luckybackup-0.5.0-nomancompress.patch b/app-backup/luckybackup/files/luckybackup-0.5.0-nomancompress.patch
new file mode 100644
index 000000000000..b043182160f1
--- /dev/null
+++ b/app-backup/luckybackup/files/luckybackup-0.5.0-nomancompress.patch
@@ -0,0 +1,24 @@
+--- a/luckybackup.pro 2018-11-02 19:29:58.000000000 +0100
++++ b/luckybackup.pro 2020-06-26 13:25:02.798368937 +0200
+@@ -33,7 +33,7 @@
+ documentation.files = manual
+
+ manpage.path = /usr/share/man/man8
+-manpage.files = manpage/luckybackup.8.gz manpage/luckybackup-pkexec.8
++manpage.files = manpage/luckybackup.8 manpage/luckybackup-pkexec.8
+
+ translations.path = /usr/share/luckybackup
+ translations.files = translations
+@@ -43,10 +43,8 @@
+
+ INSTALLS += target menu polkit polkitscript pixmap documentation manpage translations license
+
+-system(gzip -c manpage/luckybackup.8 > manpage/luckybackup.8.gz)
+-QMAKE_CLEAN = Makefile $${TARGET} manpage/luckybackup.8.gz
+-system(gzip -c manpage/luckybackup-pkexec.8 > manpage/luckybackup-pkexec.8.gz)
+-QMAKE_CLEAN = Makefile $${TARGET} manpage/luckybackup-pkexec.8.gz
++QMAKE_CLEAN = Makefile $${TARGET} manpage/luckybackup.8
++QMAKE_CLEAN = Makefile $${TARGET} manpage/luckybackup-pkexec.8
+
+ greaterThan(QT_MAJOR_VERSION, 4) {
+ QT += widgets
diff --git a/app-backup/luckybackup/luckybackup-0.5.0.ebuild b/app-backup/luckybackup/luckybackup-0.5.0.ebuild
new file mode 100644
index 000000000000..b829da8b431e
--- /dev/null
+++ b/app-backup/luckybackup/luckybackup-0.5.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="Powerful and flexible backup (and syncing) tool, using RSync and Qt"
+HOMEPAGE="http://luckybackup.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}
+ net-misc/rsync
+ sys-auth/polkit
+"
+
+DOCS=( readme/{AUTHORS,README,TODO,TRANSLATIONS,changelog} )
+
+PATCHES=( "${FILESDIR}/${P}-nomancompress.patch" )
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:g" \
+ -e "s:/usr/share/doc/packages/${PN}:/usr/share/doc/${PF}:g" \
+ luckybackup.pro src/global.cpp || die "sed failed"
+
+ # bogus dependency - bug #645732
+ sed -i -e '/QT += network/s/^/#/' luckybackup.pro || die
+
+ # remove text version - cannot remove HTML version
+ # as it's used within the application
+ rm license/gpl.txt || die "rm failed"
+}
+
+src_configure() {
+ eqmake5 ${PN}.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}