summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-26 20:47:52 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-26 20:49:51 -0500
commit11ac9aad456a4852bd959d8fe9b409b47a7d2be9 (patch)
tree0b183e942766987039f012a34e88fad38636c8bf
parentdev-python/soupsieve: New package (diff)
downloadgentoo-11ac9aad456a4852bd959d8fe9b409b47a7d2be9.tar.gz
gentoo-11ac9aad456a4852bd959d8fe9b409b47a7d2be9.tar.bz2
gentoo-11ac9aad456a4852bd959d8fe9b409b47a7d2be9.zip
dev-python/pycountry: fix tests
* Tests are successful on both amd64 and arm64 but pytest was leaving behind the .pytest_cache dir causing a subsequent merge to fail. * add the cache_dir option to pytest call so that tests are run from ${T} Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--dev-python/pycountry/pycountry-18.5.26.ebuild2
-rw-r--r--dev-python/pycountry/pycountry-19.8.18.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/pycountry/pycountry-18.5.26.ebuild b/dev-python/pycountry/pycountry-18.5.26.ebuild
index bf3621a2c760..1831d0f30e7b 100644
--- a/dev-python/pycountry/pycountry-18.5.26.ebuild
+++ b/dev-python/pycountry/pycountry-18.5.26.ebuild
@@ -26,6 +26,6 @@ python_test() {
if [[ ${EPYTHON} == pypy* ]]; then
sed -e 's:test_locales:_&:' -i pycountry/tests/test_general.py || die
fi
- pytest -vv || die
+ pytest -o cache_dir="${T}" -vv || die
popd > /dev/null || die
}
diff --git a/dev-python/pycountry/pycountry-19.8.18.ebuild b/dev-python/pycountry/pycountry-19.8.18.ebuild
index 99429b4ab6c9..4e711c93a320 100644
--- a/dev-python/pycountry/pycountry-19.8.18.ebuild
+++ b/dev-python/pycountry/pycountry-19.8.18.ebuild
@@ -26,6 +26,6 @@ python_test() {
if [[ ${EPYTHON} == pypy* ]]; then
sed -e 's:test_locales:_&:' -i pycountry/tests/test_general.py || die
fi
- pytest -vv || die
+ pytest -o cache_dir="${T}" -vv || die
popd > /dev/null || die
}