summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-07 18:34:27 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-07 18:49:17 +0200
commit11ae8c5b575d92be8729b9d06cabb89c747b9f95 (patch)
tree61c76d10d9d1068661a7ed2a6cd46ac776db5181
parentdev-python/sphinx-autodoc-typehints: add 1.14.1 (diff)
downloadgentoo-11ae8c5b.tar.gz
gentoo-11ae8c5b.tar.bz2
gentoo-11ae8c5b.zip
dev-python/decorator: add 5.1.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/decorator/Manifest1
-rw-r--r--dev-python/decorator/decorator-5.1.1.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/decorator/Manifest b/dev-python/decorator/Manifest
index b8587ef1b7cd..704a70e408c9 100644
--- a/dev-python/decorator/Manifest
+++ b/dev-python/decorator/Manifest
@@ -1 +1,2 @@
DIST decorator-5.1.0.tar.gz 34900 BLAKE2B f6f4964411a31ac0904a98ec9b9e172012bd1b769122241bb0220a217da007baabe4f9173fa2283a46e25485c42910283d0e0dfc88b4bc3b68f5683448ddf84a SHA512 4acc0967af79f61c56adea3084c4e9f9de1c34fcbc7906db4bb1b0759e07ffed6eff0e4b21645dda5f37e96662742621f3d043e8c06a401841c7199a915afe18
+DIST decorator-5.1.1.tar.gz 35016 BLAKE2B 0e38ee2dea6793d489f5c50692549022f1b252ab3a7b75da5b785f856b7f18faaf5570dde2c68f6936c11460599839063e9eb8a133789a00f683761393a5103d SHA512 584857ffb0c3e52344b473ceb9e28adfd7d789d480a528471f8ab37be055ebe5feb170f41077010e25350e1c311189d45b90773cf12f0043de98ea8ebcde20ab
diff --git a/dev-python/decorator/decorator-5.1.1.ebuild b/dev-python/decorator/decorator-5.1.1.ebuild
new file mode 100644
index 000000000000..8a219708d389
--- /dev/null
+++ b/dev-python/decorator/decorator-5.1.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Simplifies the usage of decorators for the average programmer"
+HOMEPAGE="https://github.com/micheles/decorator https://pypi.org/project/decorator/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+DOCS=( CHANGES.md )
+
+python_test() {
+ "${EPYTHON}" src/tests/test.py -v || die "Tests failed with ${EPYTHON}"
+}