summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-12-09 23:23:55 +0000
committerJames Le Cuirot <chewi@gentoo.org>2022-12-09 23:23:55 +0000
commit11cd25124f9cbaa14f59254ddb846e4969f2c271 (patch)
tree68eb9d319a26c8593836932e303ad0f7699cdb22
parentx11-drivers/nvidia-drivers: add 525.60.13 (diff)
downloadgentoo-11cd2512.tar.gz
gentoo-11cd2512.tar.bz2
gentoo-11cd2512.zip
net-misc/netevent: Version bump to 2.2.1
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--net-misc/netevent/Manifest1
-rw-r--r--net-misc/netevent/netevent-2.2.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/netevent/Manifest b/net-misc/netevent/Manifest
index c45c148cba3d..de7b2ab75191 100644
--- a/net-misc/netevent/Manifest
+++ b/net-misc/netevent/Manifest
@@ -1 +1,2 @@
DIST netevent-2.0_p20200217.tar.gz 39237 BLAKE2B 543456de89c6c57c7fe086d6697ca687ce0a04fce67efda7162e516eb1dca3f31b6ce31e1f5d7481fe538364f9f597103e3b77f3864c41456c6fe9080bfb424a SHA512 921982c8d9153e627c7931059e6163213ba2ac907f4ae98bcde62645e774cc41077ee728b698f3fad6a639fda19f99f9e43103006abe645f1a4ac4d68cf393c7
+DIST netevent-2.2.1.tar.gz 40826 BLAKE2B 7620ecaead747f0684bd9f9ce0c8c3126cc67b9eafa747f43986f9e0f162f771604b4ec0e9aa070f773d4bd535a98d3164dbc9a868e1dc72ddd8063f0cd45559 SHA512 f597b82f7343b9f22c9c8533d9821763e82aeb0afddcfa109499555a6ed1e32f00f3cc9f36fe3eb5d524ad594e861382e33168ea4033a68abd15385b8edaeab9
diff --git a/net-misc/netevent/netevent-2.2.1.ebuild b/net-misc/netevent/netevent-2.2.1.ebuild
new file mode 100644
index 000000000000..af01c9e1c64e
--- /dev/null
+++ b/net-misc/netevent/netevent-2.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool to share Linux event devices with other machines"
+HOMEPAGE="https://github.com/Blub/netevent"
+SRC_URI="https://github.com/Blub/netevent/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE="doc"
+
+BDEPEND="
+ doc? ( dev-python/docutils )
+"
+
+src_configure() {
+ tc-export CXX
+
+ # Not Autoconf.
+ RST2MAN=rst2man.py \
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ $(use_enable doc) \
+ || die
+}
+
+src_compile() {
+ emake CPPFLAGS="-Wall -Wno-unknown-pragmas"
+}