summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-09-21 15:00:15 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-09-21 15:04:42 +0200
commit11dfd033459deeac330320ec5e52197769b53599 (patch)
tree1143844de098fb39c4af9c89bda6fb2a5c7294a1
parentwww-client/firefox: drop old (diff)
downloadgentoo-11dfd033.tar.gz
gentoo-11dfd033.tar.bz2
gentoo-11dfd033.zip
www-client/firefox: allow LLVM 9.x
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--eclass/mozconfig-v6.60.eclass8
-rw-r--r--www-client/firefox/firefox-60.8.0.ebuild2
-rw-r--r--www-client/firefox/firefox-60.9.0.ebuild2
-rw-r--r--www-client/firefox/firefox-68.1.0.ebuild11
-rw-r--r--www-client/firefox/firefox-69.0.1.ebuild11
5 files changed, 30 insertions, 4 deletions
diff --git a/eclass/mozconfig-v6.60.eclass b/eclass/mozconfig-v6.60.eclass
index 2a6e0e07bb60..ae83ebd6c314 100644
--- a/eclass/mozconfig-v6.60.eclass
+++ b/eclass/mozconfig-v6.60.eclass
@@ -160,6 +160,14 @@ DEPEND="app-arch/zip
sys-apps/findutils
|| (
(
+ sys-devel/clang:9
+ !clang? ( sys-devel/llvm:9 )
+ clang? (
+ =sys-devel/lld-9*
+ sys-devel/llvm:9[gold]
+ )
+ )
+ (
sys-devel/clang:8
!clang? ( sys-devel/llvm:8 )
clang? (
diff --git a/www-client/firefox/firefox-60.8.0.ebuild b/www-client/firefox/firefox-60.8.0.ebuild
index 26d72d83b619..55b73e4e2b95 100644
--- a/www-client/firefox/firefox-60.8.0.ebuild
+++ b/www-client/firefox/firefox-60.8.0.ebuild
@@ -35,7 +35,7 @@ MOZ_HTTP_URI="https://archive.mozilla.org/pub/${PN}/releases"
MOZCONFIG_OPTIONAL_WIFI=1
-LLVM_MAX_SLOT=8
+LLVM_MAX_SLOT=9
inherit check-reqs flag-o-matic toolchain-funcs eutils gnome2-utils llvm \
mozconfig-v6.60 pax-utils xdg-utils autotools mozlinguas-v2
diff --git a/www-client/firefox/firefox-60.9.0.ebuild b/www-client/firefox/firefox-60.9.0.ebuild
index 19831e39cc87..47b80028876b 100644
--- a/www-client/firefox/firefox-60.9.0.ebuild
+++ b/www-client/firefox/firefox-60.9.0.ebuild
@@ -34,7 +34,7 @@ MOZ_HTTP_URI="https://archive.mozilla.org/pub/${PN}/releases"
MOZCONFIG_OPTIONAL_WIFI=1
-LLVM_MAX_SLOT=8
+LLVM_MAX_SLOT=9
inherit check-reqs flag-o-matic toolchain-funcs eutils gnome2-utils llvm \
mozconfig-v6.60 pax-utils xdg-utils autotools mozlinguas-v2
diff --git a/www-client/firefox/firefox-68.1.0.ebuild b/www-client/firefox/firefox-68.1.0.ebuild
index d2ca2f5da566..4cf11539cb49 100644
--- a/www-client/firefox/firefox-68.1.0.ebuild
+++ b/www-client/firefox/firefox-68.1.0.ebuild
@@ -38,7 +38,7 @@ if [[ "${PV}" == *_rc* ]]; then
MOZ_SRC_URI="${MOZ_HTTP_URI}/source/${PN}-${MOZ_PV}.source.tar.xz -> $P.tar.xz"
fi
-LLVM_MAX_SLOT=8
+LLVM_MAX_SLOT=9
inherit check-reqs eapi7-ver flag-o-matic toolchain-funcs eutils \
gnome2-utils llvm mozcoreconf-v6 pax-utils xdg-utils \
@@ -126,6 +126,15 @@ DEPEND="${CDEPEND}
sys-apps/findutils
|| (
(
+ sys-devel/clang:9
+ !clang? ( sys-devel/llvm:9 )
+ clang? (
+ =sys-devel/lld-9*
+ sys-devel/llvm:9[gold]
+ pgo? ( =sys-libs/compiler-rt-sanitizers-9*[profile] )
+ )
+ )
+ (
sys-devel/clang:8
!clang? ( sys-devel/llvm:8 )
clang? (
diff --git a/www-client/firefox/firefox-69.0.1.ebuild b/www-client/firefox/firefox-69.0.1.ebuild
index 52dfab5d47de..1bdcc49ef7fc 100644
--- a/www-client/firefox/firefox-69.0.1.ebuild
+++ b/www-client/firefox/firefox-69.0.1.ebuild
@@ -38,7 +38,7 @@ if [[ "${PV}" == *_rc* ]]; then
MOZ_SRC_URI="${MOZ_HTTP_URI}/source/${PN}-${MOZ_PV}.source.tar.xz -> $P.tar.xz"
fi
-LLVM_MAX_SLOT=8
+LLVM_MAX_SLOT=9
inherit check-reqs eapi7-ver flag-o-matic toolchain-funcs eutils \
gnome2-utils llvm mozcoreconf-v6 pax-utils xdg-utils \
@@ -128,6 +128,15 @@ DEPEND="${CDEPEND}
sys-apps/findutils
|| (
(
+ sys-devel/clang:9
+ !clang? ( sys-devel/llvm:9 )
+ clang? (
+ =sys-devel/lld-9*
+ sys-devel/llvm:9[gold]
+ pgo? ( =sys-libs/compiler-rt-sanitizers-9*[profile] )
+ )
+ )
+ (
sys-devel/clang:8
!clang? ( sys-devel/llvm:8 )
clang? (