summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-06-01 10:59:21 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-06-01 11:05:19 -0500
commit11e1c7304e07cb659c07226de24450340ce0c460 (patch)
treec1580e8f0f9b46157538ecc6fb5b35391bbe838b
parentsys-cluster/libcircle: git-2->git-r3 (diff)
downloadgentoo-11e1c730.tar.gz
gentoo-11e1c730.tar.bz2
gentoo-11e1c730.zip
app-admin/ansible: 2.5.4 bup
Package-Manager: Portage-2.3.36, Repoman-2.3.9
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-2.5.4.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 7a85c4353914..cae36392ed65 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -3,3 +3,4 @@ DIST ansible-2.4.3.0.tar.gz 6511115 BLAKE2B d43679c651f6aa5fd86c797a204645a8ee98
DIST ansible-2.4.4.0.tar.gz 6512938 BLAKE2B 51e397d2242209271a8aef211c3bdeb34a15e2061a202415749ecb4232e0521aff304d5585d536b1805f14ff476b0733d559eeabe6e44de7b273b8606b11b805 SHA512 f0dcf92f2c69931fa06e6dd3845c11592d5a7e44f19a99c4d6c361022708560170f2b74ad20eded61fa5812c90eed281b78396aa92e0b33717970afb5966dd72
DIST ansible-2.5.2.tar.gz 10105800 BLAKE2B 0d9080b666164c96c2a237f9a5f4b271a2fe9933d1999df85cd973df0cf85d850343bc33b8afb18c1bf0a7eecb2ab193e91c7a02c3e56e8a5e41338ce7a90081 SHA512 25568665b96ee9d7ca0888dadd90de178a9cc1da7dba07acb682ca4455ef91622344958ec2000eafbb4cfda87aec325be77d3d5b395aa4bbc2d180fad1a90a34
DIST ansible-2.5.3.tar.gz 10138567 BLAKE2B ea79156f531db1586899f18babc72165b64e7e2d42690f3ef15d790d2d80c12c9f9e1b70ab5fc7b863538e9209a8e98368d0110fc2a79c70c42726449917255c SHA512 74aa767118773aa557cd43f2a9e17322d7a6b45ea643a9175fe4f613fd4566453dc6f1859768fce179db3331b3beba103e89dfe4eae66ed82b1a83cd7d261269
+DIST ansible-2.5.4.tar.gz 10146881 BLAKE2B 69aae30c39274ea6c082a995131054050942e334382ee6e815a0e54165c3daaf5f32e448e2d900259b39490460e0bd48c9e067fb9558276c5cea5c34027fc46b SHA512 4e39547c5df38e407b06e5f20f7caa50e599fa6283693afdbc2c808565593e908b2067b71fb287c4ad0aab8f283c8bb29bea438d534f827a37ed416c7325ea82
diff --git a/app-admin/ansible/ansible-2.5.4.ebuild b/app-admin/ansible/ansible-2.5.4.ebuild
new file mode 100644
index 000000000000..8f63e8546445
--- /dev/null
+++ b/app-admin/ansible/ansible-2.5.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1 eutils versionator
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+# not included in release tarball
+RESTRICT="test"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ doman docs/man/man1/*.1
+ dodoc -r examples
+}