summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-26 15:30:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-26 15:31:55 +0200
commit11ef9d43a4733301f4f4f81c991c3b4fd3068c2a (patch)
tree145b609da49b10ef323ce9f4e6479b4dcf914e52
parentdev-python/executing: Remove old (diff)
downloadgentoo-11ef9d43a4733301f4f4f81c991c3b4fd3068c2a.tar.gz
gentoo-11ef9d43a4733301f4f4f81c991c3b4fd3068c2a.tar.bz2
gentoo-11ef9d43a4733301f4f4f81c991c3b4fd3068c2a.zip
dev-python/hacking: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hacking/Manifest1
-rw-r--r--dev-python/hacking/hacking-2.0.0.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/hacking/Manifest b/dev-python/hacking/Manifest
index 201d4f4ff4c4..153afbe7326f 100644
--- a/dev-python/hacking/Manifest
+++ b/dev-python/hacking/Manifest
@@ -1,2 +1 @@
-DIST hacking-2.0.0.tar.gz 53296 BLAKE2B 50606d700c324acc8695499ee97cd592b051fe0cfc020efdfe7bf82b44d2f6ac858ed2f923ea08343066820c7da1686aa0b172bbab541cc564dc5ecc016cfac6 SHA512 d44d62f694c79af4c2044e745b140f0582fb5a6bbfa8050d45b17e8cb354198e8eac3a06586cf96d516844bb079d429d73ce9755a23e256857c4de19aca7ffe3
DIST hacking-4.1.0.tar.gz 61910 BLAKE2B 95ced5b2fbafbb890478b5ef598a836520b4d1a3f1f2a0e708aa3f3135f394aab9e1ca8eaafa9d2f9f8dfcd1043d925b0232228234021ac89d2882ad6c7918a5 SHA512 44741548b5031777b0a508255129893da63a076615dc4245fdcb2368711be0ff6e16702c12c75a7f2c6b13257e2257c58e6e95dfad6da6640ff077fbf2b507db
diff --git a/dev-python/hacking/hacking-2.0.0.ebuild b/dev-python/hacking/hacking-2.0.0.ebuild
deleted file mode 100644
index 29f8280c4cd2..000000000000
--- a/dev-python/hacking/hacking-2.0.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="A client for the OpenStack Nova API"
-HOMEPAGE="https://github.com/openstack-dev/hacking"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~s390 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/flake8-3.6.0[${PYTHON_USEDEP}]
- <dev-python/flake8-4.0.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- ${RDEPEND}
- )
- doc? (
- >=dev-python/sphinx-1.8.0[${PYTHON_USEDEP}]
- !~dev-python/sphinx-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
- >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
- )"
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- use doc && sphinx-build -b html -c doc/source/ doc/source/ doc/source/html
-}
-
-python_test() {
- stestr init || die "stestr init died"
- stestr run || die "testsuite failed under ${EPYTHON}"
- flake8 "${PN}"/tests || die "flake8 drew error on a run over ${PN}/tests folder"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/source/html/. )
- distutils-r1_python_install_all
-}