summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-04-26 20:38:15 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-04-26 21:20:17 +0200
commit12231ca57ada88fa29f6af837c11c5f3c0d7a3eb (patch)
treef618f7d097f7c4547b301b8a502b70d57260f24a
parentx11-themes/silver-xcursors: drop old version (diff)
downloadgentoo-12231ca57ada88fa29f6af837c11c5f3c0d7a3eb.tar.gz
gentoo-12231ca57ada88fa29f6af837c11c5f3c0d7a3eb.tar.bz2
gentoo-12231ca57ada88fa29f6af837c11c5f3c0d7a3eb.zip
x11-themes/blueglass-xcursors: add missing dep
Bug: https://bugs.gentoo.org/758236 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--x11-themes/blueglass-xcursors/blueglass-xcursors-0.4-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-themes/blueglass-xcursors/blueglass-xcursors-0.4-r1.ebuild b/x11-themes/blueglass-xcursors/blueglass-xcursors-0.4-r1.ebuild
new file mode 100644
index 000000000000..dfe195a49546
--- /dev/null
+++ b/x11-themes/blueglass-xcursors/blueglass-xcursors-0.4-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="5532-BlueGlass-XCursors-3D-${PV}"
+
+DESCRIPTION="A high quality set of Xfree 4.3.0 animated mouse cursors"
+HOMEPAGE="https://store.kde.org/p/999915/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P:5}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sparc x86"
+
+RDEPEND="x11-libs/libXcursor"
+
+# Note: although the package name is BlueGlass, the tarball & authors directions
+# use the directory 'Blue'.
+src_install() {
+ insinto /usr/share/cursors/xorg-x11/Blue
+ doins -r Blue/cursors
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ einfo "To use this set of cursors, edit or create the file ~/.Xdefaults"
+ einfo "and add the following line:"
+ einfo "Xcursor.theme: Blue"
+ einfo ""
+ einfo "You can change the size by adding a line like:"
+ einfo "Xcursor.size: 48"
+ einfo ""
+ einfo "To globally use this set of mouse cursors edit the file:"
+ einfo " ${EROOT}/usr/share/cursors/xorg-x11/default/index.theme"
+ einfo "and change the line:"
+ einfo " Inherits=[current setting]"
+ einfo "to"
+ einfo " Inherits=Blue"
+ einfo ""
+ einfo "Note this will be overruled by a user's ~/.Xdefaults file."
+ einfo
+
+ ewarn "If you experience flickering, try setting the following line in"
+ ewarn "the Device section of your XF86Config:"
+ ewarn "Option \"HWCursor\" \"false\""
+}