summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-07 20:17:10 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-07 20:17:17 +0300
commit1247a958c94d3a9fa638b23fb6971c23fe02e019 (patch)
tree81f8285aec5fb7e10873cbf1bc1ccc90d50bdc7c
parentapp-text/poppler-data: modernise ebuild (diff)
downloadgentoo-1247a958.tar.gz
gentoo-1247a958.tar.bz2
gentoo-1247a958.zip
dev-python/eventlet: add 0.32.0
Upstream is working toward python 3.10 support, so still need to wait for it. Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/eventlet/Manifest1
-rw-r--r--dev-python/eventlet/eventlet-0.32.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/eventlet/Manifest b/dev-python/eventlet/Manifest
index 67d2a481950f..f721ffa090cf 100644
--- a/dev-python/eventlet/Manifest
+++ b/dev-python/eventlet/Manifest
@@ -1 +1,2 @@
DIST eventlet-0.31.1.tar.gz 412021 BLAKE2B 6358dca8e0a766f0cc2cef37586a8d38f5d87f03d8389a7cc11b3d2d616669825df2a416ae980eed8a980f8e81ce8b2848225921bb4536f5537a7954ed75fb64 SHA512 c240a332aaf8eeb4af429d1b190ae198b4bcb92ae1bc38ade3f824634327872526267c6ff02f7196e3f9dfd17d639af500c28a3ed70a773b1b050d6d967a88a5
+DIST eventlet-0.32.0.tar.gz 412769 BLAKE2B c0b35e1ea0e3353f326f24787f253ef666c34de5a2880c0d78e9541738c47f72787e6ccb3fb861a9f651da7e501443d220809a09d31dbd6e6d75aee509258dc8 SHA512 6a8ca80ef7318114e13690f8d2cd640f1be3c716f01644a7a84cd983ab90ab00ec0962cfc7e85f071e73a6da139bbdf8ad3918f15097e94dfc97db7056d13a9d
diff --git a/dev-python/eventlet/eventlet-0.32.0.ebuild b/dev-python/eventlet/eventlet-0.32.0.ebuild
new file mode 100644
index 000000000000..5607ef1b8848
--- /dev/null
+++ b/dev-python/eventlet/eventlet-0.32.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Highly concurrent networking library"
+HOMEPAGE="https://pypi.org/project/eventlet/ https://github.com/eventlet/eventlet/"
+SRC_URI="mirror://pypi/e/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ppc ppc64 ~s390 sparc x86"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/dnspython-1.15.0[${PYTHON_USEDEP}]
+ <dev-python/dnspython-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ virtual/python-greenlet[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/eventlet-0.25.1-tests.patch"
+ "${FILESDIR}/eventlet-0.30.0-tests-socket.patch"
+ "${FILESDIR}/eventlet-0.30.2-test-timeout.patch"
+)
+
+distutils_enable_tests nose
+
+python_test() {
+ unset PYTHONPATH
+ export TMPDIR="${T}"
+ nosetests -v -x || die
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}