summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2018-12-27 20:39:19 +0100
committerDavide Pesavento <pesa@gentoo.org>2018-12-27 20:49:10 +0100
commit1252c19b894ba758e02a5efe468b9771bc76923c (patch)
treeb282317ba5968d6fca60a5574225462d343bcd1d
parentdev-python/sip: cosmetic changes to minimize diff with PyQt5-sip (diff)
downloadgentoo-1252c19b.tar.gz
gentoo-1252c19b.tar.bz2
gentoo-1252c19b.zip
dev-python/PyQt5: add 5.12 snapshot
This depends on the new private SIP module (dev-python/PyQt5-sip). Added support for QtNetworkAuth. QtWebEngine support has been removed since it is no longer present in the source tarball and will likely be packaged separately. Bug: https://bugs.gentoo.org/668014 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
-rw-r--r--dev-python/PyQt5/Manifest1
-rw-r--r--dev-python/PyQt5/PyQt5-5.12_pre1812231618.ebuild196
-rw-r--r--dev-python/PyQt5/metadata.xml1
3 files changed, 198 insertions, 0 deletions
diff --git a/dev-python/PyQt5/Manifest b/dev-python/PyQt5/Manifest
index 5d0feadf2823..7571168f27de 100644
--- a/dev-python/PyQt5/Manifest
+++ b/dev-python/PyQt5/Manifest
@@ -1,3 +1,4 @@
DIST PyQt5_gpl-5.10.1.tar.gz 3110469 BLAKE2B 75e24bd8c0739d47eff6212435aa783eaa302633beb0494f099edc3f8f99600cd03dc3cba5152ed7ae703cfe445ecae06ec5d2281dd7c0640c71db041659bd6f SHA512 04cd0292f7a088f9c0d088d7c73ec96cfc40253f771dfdf194eb92be7635e6fcaf04863fa24215e9c34a096658549bb2feeb8d8fdca1e39ed87f0256ef0f790b
DIST PyQt5_gpl-5.11.3.tar.gz 3121036 BLAKE2B e7881fea18535ba55c0b6946718fd1eccdc6a4678b869678c9413c500daee0cbfb281116db40a13655c8cb5e778b605f141821e20bf3834f1434908f73fc22bd SHA512 6f4abb1866ce357263c208121607072e127c8853e9c6bf039b034fefdda4c40e38f917c3b313375f0d692d764ecf26ff3a6b12cda2a2eeb5237db8b5e9443548
+DIST PyQt5_gpl-5.12.dev1812231618.tar.gz 3120289 BLAKE2B 2d48eaa39090ed60f971b84c96d148fba05c58fe15196f9a99c7a6c8302f364623dd0e1f0cc16d6fb527606cabf6cb072316319252b65f44c9652c1d95ca9fa6 SHA512 6a95fb02fe1eea3e7fb9a03da457a036f92f5404074e7234eeb52e5941bd247343e3d34d4054dc5a604b380fc2a227f7fe5ae250fcd4449da4a3fe856ab8eba3
DIST PyQt5_gpl-5.9.2.tar.gz 3102848 BLAKE2B b87f25693aa2b20211119f89cf13665bf88f14de8827d43ba757344ab9bdef0b0c197abb8386308c72925da263cabb6efd3f104db8a350c51fca3fba8c7c06b6 SHA512 5af2e65addaed7dd02d8dbf7a7c63767e565fc8edeb7b51e5991a00cda29f75b666529097646e821aaff556f350a929fd451f548bba76e97355b7fe10bd913bc
diff --git a/dev-python/PyQt5/PyQt5-5.12_pre1812231618.ebuild b/dev-python/PyQt5/PyQt5-5.12_pre1812231618.ebuild
new file mode 100644
index 000000000000..7db840ce9df6
--- /dev/null
+++ b/dev-python/PyQt5/PyQt5-5.12_pre1812231618.ebuild
@@ -0,0 +1,196 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+inherit multibuild python-r1 qmake-utils
+
+DESCRIPTION="Python bindings for the Qt framework"
+HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt/intro"
+
+MY_P=${PN}_gpl-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+# TODO: QtNfc, QtRemoteObjects (Qt >= 5.12)
+IUSE="bluetooth dbus debug declarative designer examples gles2 gui help location
+ multimedia network networkauth opengl positioning printsupport sensors
+ serialport sql svg testlib webchannel webkit websockets widgets x11extras
+ xmlpatterns"
+
+# The requirements below were extracted from configure.py
+# and from the output of 'grep -r "%Import " "${S}"/sip'
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ bluetooth? ( gui )
+ declarative? ( gui network )
+ designer? ( widgets )
+ help? ( gui widgets )
+ location? ( positioning )
+ multimedia? ( gui network )
+ networkauth? ( network )
+ opengl? ( gui widgets )
+ positioning? ( gui )
+ printsupport? ( gui widgets )
+ sensors? ( gui )
+ serialport? ( gui )
+ sql? ( widgets )
+ svg? ( gui widgets )
+ testlib? ( widgets )
+ webchannel? ( network )
+ webkit? ( gui network printsupport widgets )
+ websockets? ( network )
+ widgets? ( gui )
+ xmlpatterns? ( network )
+"
+
+# Minimal supported version of Qt.
+QT_PV="5.10:5"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/PyQt5-sip-4.19.14_pre:=[${PYTHON_USEDEP}]
+ >=dev-qt/qtcore-${QT_PV}
+ >=dev-qt/qtxml-${QT_PV}
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ bluetooth? ( >=dev-qt/qtbluetooth-${QT_PV} )
+ dbus? (
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-qt/qtdbus-${QT_PV}
+ )
+ declarative? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
+ designer? ( >=dev-qt/designer-${QT_PV} )
+ gui? ( >=dev-qt/qtgui-${QT_PV}[gles2=] )
+ help? ( >=dev-qt/qthelp-${QT_PV} )
+ location? ( >=dev-qt/qtlocation-${QT_PV} )
+ multimedia? ( >=dev-qt/qtmultimedia-${QT_PV}[widgets?] )
+ network? ( >=dev-qt/qtnetwork-${QT_PV} )
+ networkauth? ( >=dev-qt/qtnetworkauth-${QT_PV} )
+ opengl? ( >=dev-qt/qtopengl-${QT_PV} )
+ positioning? ( >=dev-qt/qtpositioning-${QT_PV} )
+ printsupport? ( >=dev-qt/qtprintsupport-${QT_PV} )
+ sensors? ( >=dev-qt/qtsensors-${QT_PV} )
+ serialport? ( >=dev-qt/qtserialport-${QT_PV} )
+ sql? ( >=dev-qt/qtsql-${QT_PV} )
+ svg? ( >=dev-qt/qtsvg-${QT_PV} )
+ testlib? ( >=dev-qt/qttest-${QT_PV} )
+ webchannel? ( >=dev-qt/qtwebchannel-${QT_PV} )
+ webkit? ( dev-qt/qtwebkit:5[printsupport] )
+ websockets? ( >=dev-qt/qtwebsockets-${QT_PV} )
+ widgets? ( >=dev-qt/qtwidgets-${QT_PV} )
+ x11extras? ( >=dev-qt/qtx11extras-${QT_PV} )
+ xmlpatterns? ( >=dev-qt/qtxmlpatterns-${QT_PV} )
+"
+DEPEND="${RDEPEND}
+ >=dev-python/sip-4.19.14_pre[${PYTHON_USEDEP}]
+ dbus? ( virtual/pkgconfig )
+"
+
+S=${WORKDIR}/${MY_P}
+
+pyqt_use_enable() {
+ use "$1" || return
+
+ if [[ $# -eq 1 ]]; then
+ echo --enable=Qt$(tr 'a-z' 'A-Z' <<< ${1:0:1})${1:1}
+ else
+ shift
+ echo ${@/#/--enable=}
+ fi
+}
+
+src_configure() {
+ configuration() {
+ local myconf=(
+ "${PYTHON}"
+ "${S}"/configure.py
+ $(usex debug '--debug --qml-debug --trace' '')
+ --verbose
+ --confirm-license
+ --qmake="$(qt5_get_bindir)"/qmake
+ --bindir="${EPREFIX}/usr/bin"
+ --sip-incdir="$(python_get_includedir)"
+ --qsci-api
+ --enable=QtCore
+ --enable=QtXml
+ $(pyqt_use_enable bluetooth)
+ $(pyqt_use_enable dbus QtDBus)
+ $(usex dbus '' --no-python-dbus)
+ $(pyqt_use_enable declarative QtQml QtQuick $(usex widgets QtQuickWidgets ''))
+ $(usex declarative '' --no-qml-plugin)
+ $(pyqt_use_enable designer)
+ $(usex designer '' --no-designer-plugin)
+ $(pyqt_use_enable gui)
+ $(pyqt_use_enable gui $(use gles2 && echo _QOpenGLFunctions_ES2 || echo _QOpenGLFunctions_{2_0,2_1,4_1_Core}))
+ $(pyqt_use_enable help)
+ $(pyqt_use_enable location)
+ $(pyqt_use_enable multimedia QtMultimedia $(usex widgets QtMultimediaWidgets ''))
+ $(pyqt_use_enable network)
+ $(pyqt_use_enable networkauth QtNetworkAuth)
+ $(pyqt_use_enable opengl QtOpenGL)
+ $(pyqt_use_enable positioning)
+ $(pyqt_use_enable printsupport QtPrintSupport)
+ $(pyqt_use_enable sensors)
+ $(pyqt_use_enable serialport QtSerialPort)
+ $(pyqt_use_enable sql)
+ $(pyqt_use_enable svg)
+ $(pyqt_use_enable testlib QtTest)
+ $(pyqt_use_enable webchannel QtWebChannel)
+ $(pyqt_use_enable webkit QtWebKit QtWebKitWidgets)
+ $(pyqt_use_enable websockets QtWebSockets)
+ $(pyqt_use_enable widgets)
+ $(pyqt_use_enable x11extras QtX11Extras)
+ $(pyqt_use_enable xmlpatterns QtXmlPatterns)
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+
+ eqmake5 -recursive ${PN}.pro
+ }
+ python_foreach_impl run_in_build_dir configuration
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ local tmp_root=${D}/${PN}_tmp_root
+ # parallel install fails (same issue as qscintilla-python-2.10.8)
+ emake -j1 INSTALL_ROOT="${tmp_root}" install
+
+ local bin_dir=${tmp_root}${EPREFIX}/usr/bin
+ local exe
+ for exe in pylupdate5 pyrcc5 pyuic5; do
+ python_doexe "${bin_dir}/${exe}"
+ rm "${bin_dir}/${exe}" || die
+ done
+
+ local uic_dir=${tmp_root}$(python_get_sitedir)/${PN}/uic
+ if python_is_python3; then
+ rm -r "${uic_dir}"/port_v2 || die
+ else
+ rm -r "${uic_dir}"/port_v3 || die
+ fi
+
+ multibuild_merge_root "${tmp_root}" "${D}"
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+
+ einstalldocs
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/PyQt5/metadata.xml b/dev-python/PyQt5/metadata.xml
index 9983da586269..92725cf1722d 100644
--- a/dev-python/PyQt5/metadata.xml
+++ b/dev-python/PyQt5/metadata.xml
@@ -16,6 +16,7 @@
<flag name="location">Build bindings for the QtLocation module</flag>
<flag name="multimedia">Build bindings for the QtMultimedia module</flag>
<flag name="network">Build bindings for the QtNetwork module</flag>
+ <flag name="networkauth">Build bindings for the QtNetworkAuth module</flag>
<flag name="opengl">Build bindings for the QtOpenGL module</flag>
<flag name="positioning">Build bindings for the QtPositioning module</flag>
<flag name="printsupport">Build bindings for the QtPrintSupport module</flag>