summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorM. J. Everitt <m.j.everitt@iee.org>2018-04-01 05:07:23 +0100
committerMichał Górny <mgorny@gentoo.org>2018-04-05 23:33:17 +0200
commit1253532b83e2274b59ce1c5d00e59eaa83344cc0 (patch)
tree3825cb16ce683fc25b6304435e65c270c4bf2860
parentsys-apps/etckeeper: Update SRC_URI, inherit, fix misc items (diff)
downloadgentoo-1253532b83e2274b59ce1c5d00e59eaa83344cc0.tar.gz
gentoo-1253532b83e2274b59ce1c5d00e59eaa83344cc0.tar.bz2
gentoo-1253532b83e2274b59ce1c5d00e59eaa83344cc0.zip
sys-apps/etckeeper: Bump to v1.18.7
Closes: https://github.com/gentoo/gentoo/pull/6259 Package-Manager: Portage-2.3.13, Repoman-2.3.3
-rw-r--r--sys-apps/etckeeper/Manifest1
-rw-r--r--sys-apps/etckeeper/etckeeper-1.18.7.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/sys-apps/etckeeper/Manifest b/sys-apps/etckeeper/Manifest
index b8d805cf951b..4643b0b07fa6 100644
--- a/sys-apps/etckeeper/Manifest
+++ b/sys-apps/etckeeper/Manifest
@@ -1 +1,2 @@
DIST etckeeper-1.18.6.tar.gz 73487 BLAKE2B 2ec0a0ff2d87879586328de638212cbbf3bc0c87d9b1869beb6509f6b445996411d0116ecb2c4d407b3329a7b1a555f00077d20630fbbd45b2d75527d9d4c6ca SHA512 a5a3a4677f31cf1d010ab40ed37ce602c71c2e8ebf2273bf8be6dc8209f603ae0fc6a2c0d5d60d9a9d9aa4f3e7b7c0037534890cbc67b38132e5f654abcda04c
+DIST etckeeper-1.18.7.tar.gz 77568 BLAKE2B 168b5b683c25a60c6626a678aed2f650106d4db554acbc239a2cd3c937f4b399ccca4f28fded30175c5787d8bd0907a25d62e6566e7902a2e914cd01513a8c2e SHA512 44b8f66b95663da1370943128bb5673e57bd7b9df7e727c93baea5dfc79852ebba9d0834827fed19722668849d3ed18b045db5cb42135e198576a2b839523d1a
diff --git a/sys-apps/etckeeper/etckeeper-1.18.7.ebuild b/sys-apps/etckeeper/etckeeper-1.18.7.ebuild
new file mode 100644
index 000000000000..f18078fe62db
--- /dev/null
+++ b/sys-apps/etckeeper/etckeeper-1.18.7.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit bash-completion-r1 prefix python-r1
+
+DESCRIPTION="A collection of tools to let /etc be stored in a repository"
+HOMEPAGE="https://etckeeper.branchable.com/"
+SRC_URI="https://git.joeyh.name/index.cgi/etckeeper.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0"
+IUSE="bazaar cron test"
+REQUIRED_USE="bazaar? ( ${PYTHON_REQUIRED_USE} )"
+
+VCS_DEPEND="dev-vcs/git
+ dev-vcs/mercurial
+ dev-vcs/darcs"
+DEPEND="bazaar? ( dev-vcs/bzr[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}
+ app-portage/portage-utils
+ cron? ( virtual/cron )
+ bazaar? ( ${PYTHON_DEPS} )
+ !bazaar? ( || ( ${VCS_DEPEND} ) )"
+DEPEND="${DEPEND}
+ test? ( dev-util/bats )"
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.18.6-gentoo.patch )
+
+src_compile() {
+ :
+}
+
+src_install(){
+ emake DESTDIR="${ED}" install
+
+ bzr_install() {
+ "${EPYTHON}" ./${PN}-bzr/__init__.py install --root="${ED}" ||
+ die "bzr support installation failed!"
+ }
+ use bazaar && python_foreach_impl bzr_install
+
+ if use prefix; then
+ doenvd "${FILESDIR}"/99${PN}
+ eprefixify "${ED%/}"/etc/env.d/99${PN}
+ fi
+
+ newbashcomp bash_completion ${PN}
+ dodoc doc/README.mdwn
+ newdoc "${FILESDIR}"/bashrc-r1 bashrc.example
+
+ if use cron ; then
+ exeinto /etc/cron.daily
+ newexe debian/cron.daily etckeeper
+ fi
+}
+
+pkg_postinst(){
+ elog "${PN} supports the following VCS: ${VCS_DEPEND}"
+ elog " dev-vcs/bzr"
+ elog "This ebuild just ensures at least one is installed!"
+ elog "For dev-vcs/bzr you need to enable 'bazaar' useflag."
+ elog
+ elog "You may want to adjust your /etc/portage/bashrc"
+ elog "see the example file in /usr/share/doc/${PF}/examples"
+ elog
+ elog "To initialise your etc-dir as a repository run:"
+ elog "${PN} init -d /etc"
+}