summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-02 17:06:11 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-02 17:06:11 -0700
commit1253d6279bafdea70a18c3e506e05c151026fbf7 (patch)
treef6b37f121837963c0e1a6d1adfbe9bb67de9f389
parentgnome-extra/zenity: Version bump to 3.42.0 (diff)
downloadgentoo-1253d627.tar.gz
gentoo-1253d627.tar.bz2
gentoo-1253d627.zip
sys-fs/squashfs-tools-ng: Version bump to 1.1.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--sys-fs/squashfs-tools-ng/Manifest1
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.1.4.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools-ng/Manifest b/sys-fs/squashfs-tools-ng/Manifest
index cd99c985f901..1992a8f0a8b8 100644
--- a/sys-fs/squashfs-tools-ng/Manifest
+++ b/sys-fs/squashfs-tools-ng/Manifest
@@ -1 +1,2 @@
DIST squashfs-tools-ng-1.1.3.tar.xz 1181268 BLAKE2B 0d72cc82d937f7403fb67030d799cce37062496bb5dddf68f2151243b99934104e4e576e45bc6bcb2229b1f9eca134482de3180f0035229d829e785fdf0d5d03 SHA512 7a42a540622c324f500e21d64bc57bc203069c6e1deb2624597a767d8267b719bd8f76fbfa0166b7e2d4a6f9acd3d2a46514a45fcb4760052d45c7e1861da94e
+DIST squashfs-tools-ng-1.1.4.tar.xz 1311684 BLAKE2B b976ac223d57919958e0ad04c989e0a9cf2837e1c7ef1e1962069b4796b492fe2fc99c59d1e38b11e380226dc2fc4b2e25e29244635a32d03d0667f2b3ef1d7f SHA512 10e0bebd70de686862f1473588cdbf922ad766c86b64ebd4d6338fd863f862fe0c9374950fa54a197c0f02021c63943cf1ba57ebb7f93a4188e68e2b25b4a800
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.1.4.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.1.4.ebuild
new file mode 100644
index 000000000000..46990a47a6dc
--- /dev/null
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.1.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A new set of tools for working with SquashFS images"
+HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
+if [[ ${PV} = 9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
+fi
+
+LICENSE="LGPL-3+ tools? ( GPL-3+ )"
+SLOT="0"
+IUSE="lz4 +lzma lzo selinux +tools zstd"
+
+DEPEND="
+ sys-libs/zlib:=
+ lz4? ( app-arch/lz4:= )
+ lzma? ( app-arch/xz-utils:= )
+ lzo? ( dev-libs/lzo:= )
+ selinux? ( sys-libs/libselinux:= )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_with lz4)
+ $(use_with lzo)
+ $(use_with selinux)
+ $(use_with tools)
+ $(use_with lzma xz)
+ $(use_with zstd)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}