summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-02-22 23:20:59 +1300
committerKent Fredric <kentfredric@gmail.com>2016-02-27 21:39:56 +1300
commit1258ab0a1ca6313b29629213823cc32effe95e88 (patch)
treefbbc98651f0d7300cb143548e72b092636ab90c3
parentdev-perl/MIME-EncWords: Bump to version 1.14.3 (diff)
downloadgentoo-1258ab0a.tar.gz
gentoo-1258ab0a.tar.bz2
gentoo-1258ab0a.zip
dev-perl/MIME-Lite: Bump to version 3.30.0
- use EAPI6 - Patch out mess in Makefile.PL - Patch out bad tests Package-Manager: portage-2.2.27
-rw-r--r--dev-perl/MIME-Lite/MIME-Lite-3.30.0.ebuild41
-rw-r--r--dev-perl/MIME-Lite/Manifest1
-rw-r--r--dev-perl/MIME-Lite/files/3.030-makefilepl.patch43
3 files changed, 85 insertions, 0 deletions
diff --git a/dev-perl/MIME-Lite/MIME-Lite-3.30.0.ebuild b/dev-perl/MIME-Lite/MIME-Lite-3.30.0.ebuild
new file mode 100644
index 000000000000..2b425cf45d28
--- /dev/null
+++ b/dev-perl/MIME-Lite/MIME-Lite-3.30.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=3.030
+inherit perl-module
+
+DESCRIPTION="Low-calorie MIME generator"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="minimal"
+
+PATCHES=("${FILESDIR}/${DIST_VERSION}-makefilepl.patch")
+PERL_RM_FILES=(
+ "t/pod.t"
+ "t/pod-coverage.t"
+)
+# MIME::QuotedPrint -> perl-MIME-Base64
+# Mail::Address -> MailTools
+RDEPEND="
+ !minimal? (
+ virtual/perl-MIME-Base64
+ >=dev-perl/MIME-Types-1.280.0
+ >=dev-perl/MailTools-1.620.0
+ )
+ dev-perl/Email-Date-Format
+ virtual/perl-File-Spec
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+src_install() {
+ perl-module_src_install
+ insinto /usr/share/${PN}
+ doins -r contrib
+}
diff --git a/dev-perl/MIME-Lite/Manifest b/dev-perl/MIME-Lite/Manifest
index cbaf7b1646eb..4fb303b9752a 100644
--- a/dev-perl/MIME-Lite/Manifest
+++ b/dev-perl/MIME-Lite/Manifest
@@ -1 +1,2 @@
DIST MIME-Lite-3.029.tar.gz 64651 SHA256 79cc876ccedcf928c89d232c6bdba8894014c6c37003b4ab5adc03a7de11c87f SHA512 b60a435d9db3db2c4622a801418af21a499381b4e1d42e67383661211e82aeff341588a4570bc51cfed5c8b44c54c657eb64995caf61405c6aabd1b4c0859153 WHIRLPOOL e81b6b4b3a6e4d63a69cf8b79bdeaf8a853f2db1e914278781554e600811a592c6a2c94ad69bb0ec07c729b2a8dc8bd401407b72158896cd65de6f3d64c9b346
+DIST MIME-Lite-3.030.tar.gz 81830 SHA256 8f39901bc580bc3dce69e10415305e4435ff90264c63d29f707b4566460be962 SHA512 978cb234d16afcfc9b2fa16c74de04ee74f3a1050b28f7d380d64c8c8688c6d75452d7bc4c7b2575800455a45cdde477e05e8afe2b962ef2527c3ecc265d1158 WHIRLPOOL d807cb139a74ff97c0544f75342205acc736231fdfe3681f5ed6f864bfc9a4bbd108d5b56c93b6456d98ce721be9a12c5a66e3fd31c62fdf9fe60d5915ac714e
diff --git a/dev-perl/MIME-Lite/files/3.030-makefilepl.patch b/dev-perl/MIME-Lite/files/3.030-makefilepl.patch
new file mode 100644
index 000000000000..1fea2f7f53a4
--- /dev/null
+++ b/dev-perl/MIME-Lite/files/3.030-makefilepl.patch
@@ -0,0 +1,43 @@
+diff -Naur MIME-Lite-3.030/Makefile.PL MIME-Lite-3.030.new/Makefile.PL
+--- MIME-Lite-3.030/Makefile.PL 2013-11-04 02:04:48.000000000 +0000
++++ MIME-Lite-3.030.new/Makefile.PL 2016-02-22 10:15:49.107771292 +0000
+@@ -5,39 +5,12 @@
+ #------------------------------------------------------------
+ # Makefile:
+ #------------------------------------------------------------
+-my %extra_prereq = (
+- 'Mail::Address' => 1.62,
+- 'MIME::Types' => 1.28,
+- 'MIME::Base64' => undef,
+- 'MIME::QuotedPrint' => undef,
+-);
+-
+-for my $module (sort keys %extra_prereq) {
+- local $@;
+- my $ok = eval "require $module; \$extra_prereq{\$module} && \$module->VERSION(\$extra_prereq{\$module}); 1";
+- delete $extra_prereq{ $module } if $ok;
+-}
+-
+ my %prereq = (
+ 'File::Spec' => 0,
+ 'File::Basename' => 0,
+ 'Email::Date::Format' => '1.000', # first release
+ );
+
+-if (%extra_prereq) {
+- print "MIME::Lite is designed to take advantage of a variety of external modules\n",
+- "if they are not present then MIME::Lite will attempt to do its best\n",
+- "but its strongly recommend that you install them.\n\n",
+- "These modules are:\n",
+- (map {; "\t$_\n" } sort keys %extra_prereq),
+- "I can add these modules to the prereq list which will cause the files to be\n",
+- "automatically installed if they aren't already present\n";
+-
+- if (prompt("Add prereqs?",'Yes')=~/y/i) {
+- %prereq = (%prereq, %extra_prereq);
+- }
+-}
+-
+ # Write the Makefile:
+ WriteMakefile(
+ NAME => 'MIME::Lite',