summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2021-06-27 15:38:48 +0000
committerKeri Harris <keri@gentoo.org>2021-06-27 15:38:48 +0000
commit125967d1c7cbbf7f23fcbc9bd081ab20c8816b7c (patch)
tree60236547d00e4b91b705fc8e7fd529486f29da2f
parentdev-lang/mozart: include site-lisp file to get Oz major modes. (diff)
downloadgentoo-125967d1.tar.gz
gentoo-125967d1.tar.bz2
gentoo-125967d1.zip
dev-lang/logtalk: version bump
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Keri Harris <keri@gentoo.org>
-rw-r--r--dev-lang/logtalk/Manifest1
-rw-r--r--dev-lang/logtalk/files/logtalk-3.47.0-portage.patch19
-rw-r--r--dev-lang/logtalk/logtalk-3.47.0.ebuild134
3 files changed, 154 insertions, 0 deletions
diff --git a/dev-lang/logtalk/Manifest b/dev-lang/logtalk/Manifest
index 9e704668b23b..ef03f23e10e3 100644
--- a/dev-lang/logtalk/Manifest
+++ b/dev-lang/logtalk/Manifest
@@ -1 +1,2 @@
DIST logtalk-3.36.0.tar.bz2 18373894 BLAKE2B 3f4917dea47b32760edfde0538a260e5405b566520c514ec137766d17ad532f1d3e3a7a6d05b4b643b21933073951ed41bf92161ae49545eb458619444b10210 SHA512 0e93f091cb24aed3b08db05df29484e708e14cf58a673a42df70c899f3bafae30896be118d89dfdf3f3cb7d4ba520a815e46d563dd7418f80912b7067ed7da8e
+DIST logtalk-3.47.0.tar.bz2 26219166 BLAKE2B 9492d27ac041562c57ab1f5f111e0f7ad062268e20d8128284d8d5085ec1c3dc63db6efa0f3a4dac34f83f206c3a4b9827d5245191227000ae56cd306da3b699 SHA512 cf07c1dec80131e477cfc9f2bf31bae573cc01222f3fba70452663dbddbddaee68b25da2e4c0abec18e1bda46059c23fca2c012cb59bbdcb4298a8c89e2d93d4
diff --git a/dev-lang/logtalk/files/logtalk-3.47.0-portage.patch b/dev-lang/logtalk/files/logtalk-3.47.0-portage.patch
new file mode 100644
index 000000000000..2107b114da0f
--- /dev/null
+++ b/dev-lang/logtalk/files/logtalk-3.47.0-portage.patch
@@ -0,0 +1,19 @@
+--- logtalk-3.47.0.orig/scripts/logtalk_user_setup.sh 2021-05-31 23:10:00.000000000 -0000
++++ logtalk-3.47.0/scripts/logtalk_user_setup.sh 2021-06-27 15:05:04.783245715 -0000
+@@ -134,16 +134,6 @@
+ rm -f "$LOGTALKUSER"/tools/lgtdoc/xml/lgt2*
+ rm -f "$LOGTALKUSER"/tools/lgtdoc/xml/logtalk.dtd
+ rm -f "$LOGTALKUSER"/tools/lgtdoc/xml/logtalk.xsd
+-ln -sf "$LOGTALKHOME"/ACKNOWLEDGMENTS.md "$LOGTALKUSER"/ACKNOWLEDGMENTS.md
+-ln -sf "$LOGTALKHOME"/BIBLIOGRAPHY.bib "$LOGTALKUSER"/BIBLIOGRAPHY.bib
+-ln -sf "$LOGTALKHOME"/CONTRIBUTING.md "$LOGTALKUSER"/CONTRIBUTING.md
+-ln -sf "$LOGTALKHOME"/CUSTOMIZE.md "$LOGTALKUSER"/CUSTOMIZE.md
+-ln -sf "$LOGTALKHOME"/INSTALL.md "$LOGTALKUSER"/INSTALL.md
+-ln -sf "$LOGTALKHOME"/LICENSE.txt "$LOGTALKUSER"/LICENSE.txt
+-ln -sf "$LOGTALKHOME"/QUICK_START.md "$LOGTALKUSER"/QUICK_START.md
+-ln -sf "$LOGTALKHOME"/README.md "$LOGTALKUSER"/README.md
+-ln -sf "$LOGTALKHOME"/RELEASE_NOTES.md "$LOGTALKUSER"/RELEASE_NOTES.md
+-ln -sf "$LOGTALKHOME"/UPGRADING.md "$LOGTALKUSER"/UPGRADING.md
+ ln -sf "$LOGTALKHOME"/adapters "$LOGTALKUSER"/adapters
+ ln -sf "$LOGTALKHOME"/coding "$LOGTALKUSER"/coding
+ ln -sf "$LOGTALKHOME"/integration "$LOGTALKUSER"/integration
diff --git a/dev-lang/logtalk/logtalk-3.47.0.ebuild b/dev-lang/logtalk/logtalk-3.47.0.ebuild
new file mode 100644
index 000000000000..962a886f27d5
--- /dev/null
+++ b/dev-lang/logtalk/logtalk-3.47.0.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit xdg-utils
+
+DESCRIPTION="Open source object-oriented logic programming language"
+HOMEPAGE="https://logtalk.org"
+SRC_URI="https://logtalk.org/files/${P}.tar.bz2"
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="fop xslt"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ xslt? ( dev-libs/libxslt )
+ fop? ( dev-java/fop )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-portage.patch
+)
+
+src_install() {
+ # Look at scripts/install.sh for upstream installation process.
+ # Install logtalk base
+ mv scripts/logtalk_user_setup.sh integration/
+ mkdir -p "${ED}/usr/share/${P}" || die
+ cp -r adapters coding contributions core docs examples integration \
+ library manuals paths scratch tests tools VERSION.txt \
+ loader-sample.lgt settings-sample.lgt tester-sample.lgt \
+ tests-sample.lgt \
+ "${ED}/usr/share/${P}" \
+ || die "Failed to install files"
+
+ # Install mime file, the database will be updated later
+ insinto /usr/share/mime/packages
+ doins scripts/freedesktop/logtalk.xml
+
+ # Install documentation
+ dodoc ACKNOWLEDGMENTS.md BIBLIOGRAPHY.bib CONTRIBUTING.md \
+ CUSTOMIZE.md INSTALL.md LICENSE.txt QUICK_START.md \
+ README.md RELEASE_NOTES.md UPGRADING.md VERSION.txt
+
+ rm -f man/man1/logtalk_backend_select.1
+ rm -f man/man1/logtalk_version_select.1
+ doman man/man1/*.1
+
+ # Integration symlinks
+ dosym ../share/${P}/integration/logtalk_user_setup.sh \
+ /usr/bin/logtalk_user_setup
+ dosym ../share/${P}/integration/bplgt.sh \
+ /usr/bin/bplgt
+ dosym ../share/${P}/integration/ciaolgt.sh \
+ /usr/bin/ciaolgt
+ dosym ../share/${P}/integration/cxlgt.sh \
+ /usr/bin/cxlgt
+ dosym ../share/${P}/integration/eclipselgt.sh \
+ /usr/bin/eclipselgt
+ dosym ../share/${P}/integration/gplgt.sh \
+ /usr/bin/gplgt
+ dosym ../share/${P}/integration/jiplgt.sh \
+ /usr/bin/jiplgt
+ dosym ../share/${P}/integration/lvmlgt.sh \
+ /usr/bin/lvmlgt
+ dosym ../share/${P}/integration/quintuslgt.sh \
+ /usr/bin/quintuslgt
+ dosym ../share/${P}/integration/scryerlgt.sh \
+ /usr/bin/scryerlgt
+ dosym ../share/${P}/integration/sicstuslgt.sh \
+ /usr/bin/sicstuslgt
+ dosym ../share/${P}/integration/swilgt.sh \
+ /usr/bin/swilgt
+ dosym ../share/${P}/integration/taulgt.sh \
+ /usr/bin/taulgt
+ dosym ../share/${P}/integration/tplgt.sh \
+ /usr/bin/tplgt
+ dosym ../share/${P}/integration/xsblgt.sh \
+ /usr/bin/xsblgt
+ dosym ../share/${P}/integration/yaplgt.sh \
+ /usr/bin/yaplgt
+
+ dosym ../share/${P}/tools/lgtdoc/xml/lgt2xml.sh \
+ /usr/bin/lgt2xml
+ use xslt && dosym ../share/${P}/tools/lgtdoc/xml/lgt2html.sh \
+ /usr/bin/lgt2html
+ use xslt && dosym ../share/${P}/tools/lgtdoc/xml/lgt2txt.sh \
+ /usr/bin/lgt2txt
+ use xslt && dosym ../share/${P}/tools/lgtdoc/xml/lgt2md.sh \
+ /usr/bin/lgt2md
+ use fop && dosym ../share/${P}/tools/lgtdoc/xml/lgt2pdf.sh \
+ /usr/bin/lgt2pdf
+
+ # Install environment files
+ echo "LOGTALKHOME=/usr/share/${P}" > 99logtalk
+ doenvd 99logtalk
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+
+ ewarn "The following integration scripts are installed"
+ ewarn "for running logtalk with selected Prolog compilers:"
+ ewarn "B-Prolog: /usr/bin/bplgt"
+ ewarn "Ciao Prolog: /usr/bin/ciaolgt"
+ ewarn "CxProlog: /usr/bin/cxlgt"
+ ewarn "ECLiPSe: /usr/bin/eclipselgt"
+ ewarn "GNU Prolog: /usr/bin/gplgt"
+ ewarn "JIProlog: /usr/bin/jiplgt"
+ ewarn "LVM: /usr/bin/lvmlgt"
+ ewarn "Quintus Prolog: /usr/bin/quintuslgt"
+ ewarn "Scryer Prolog: /usr/bin/scryerlgt"
+ ewarn "SICStus Prolog: /usr/bin/sicstuslgt"
+ ewarn "SWI Prolog: /usr/bin/swilgt"
+ ewarn "Tau Prolog: /usr/bin/taulgt"
+ ewarn "Trealla Prolog: /usr/bin/tplgt"
+ ewarn "XSB: /usr/bin/xsblgt"
+ ewarn "YAP: /usr/bin/yaplgt"
+ ewarn ""
+
+ ewarn "The environment has been set up to make the above"
+ ewarn "integration scripts find files automatically for logtalk."
+ ewarn "Please run 'etc-update && source /etc/profile' to update"
+ ewarn "the environment now, otherwise it will be updated at next"
+ ewarn "login."
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}