summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Lothian <mike@fireburn.co.uk>2022-04-30 15:27:28 +0100
committerMatt Turner <mattst88@gentoo.org>2022-05-03 08:15:27 -0700
commit1265a159743d7f07185acba421e98d46f2cd5fc1 (patch)
treec56896b782b11d00a771efb445ef65e2c1fb9e80
parentprofiles/arch/powerpc/ppc64: mask >=dev-java/stax2-api-4.2.1-r1 (diff)
downloadgentoo-1265a159.tar.gz
gentoo-1265a159.tar.bz2
gentoo-1265a159.zip
media-libs/mesa: Add USE flag to enable proprietary codecs
Since https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/15258 patent encumbered codes have been disabled as default Use the chromium flag proprietary-codecs to reenable them for those that want them Closes: https://github.com/gentoo/gentoo/pull/25268 Signed-off-by: Mike Lothian <mike@fireburn.co.uk> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-libs/mesa/mesa-9999.ebuild4
-rw-r--r--media-libs/mesa/metadata.xml1
2 files changed, 4 insertions, 1 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index a01a3030e452..1946beb71fda 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -34,7 +34,8 @@ done
IUSE="${IUSE_VIDEO_CARDS}
cpu_flags_x86_sse2 d3d9 debug gles1 +gles2 +llvm
- lm-sensors opencl osmesa selinux test unwind vaapi valgrind vdpau vulkan
+ lm-sensors opencl osmesa +proprietary-codecs selinux
+ test unwind vaapi valgrind vdpau vulkan
vulkan-overlay wayland +X xa xvmc zink +zstd"
REQUIRED_USE="
@@ -434,6 +435,7 @@ multilib_src_configure() {
$(meson_feature zstd)
$(meson_use cpu_flags_x86_sse2 sse2)
-Dvalgrind=$(usex valgrind auto disabled)
+ -Dvideo-codecs=$(usex proprietary-codecs "h264dec,h264enc,h265dec,h265enc,vc1dec" "")
-Dgallium-drivers=$(driver_list "${GALLIUM_DRIVERS[*]}")
-Dvulkan-drivers=$(driver_list "${VULKAN_DRIVERS[*]}")
--buildtype $(usex debug debug plain)
diff --git a/media-libs/mesa/metadata.xml b/media-libs/mesa/metadata.xml
index 2b18aba1b084..ccfa51c3b7c0 100644
--- a/media-libs/mesa/metadata.xml
+++ b/media-libs/mesa/metadata.xml
@@ -17,6 +17,7 @@
<flag name="lm-sensors">Enable Gallium HUD lm-sensors support.</flag>
<flag name="opencl">Enable the Clover Gallium OpenCL state tracker.</flag>
<flag name="osmesa">Build the Mesa library for off-screen rendering.</flag>
+ <flag name="proprietary-codecs">Enable codecs for patent-encumbered audio and video formats.</flag>
<flag name="valgrind">Compile in valgrind memory hints</flag>
<flag name="vdpau">Enable the VDPAU acceleration interface for the Gallium3D Video Layer.</flag>
<flag name="vulkan">Enable Vulkan drivers</flag>