summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2017-07-16 00:02:54 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2017-07-16 00:50:07 +0300
commit1269ef4790d364ccfb1788215039632671d978f8 (patch)
tree2fde3027110a652b7632c3545ea3279c7540a333
parentgames-engines/renpy: remove old maintainers (diff)
downloadgentoo-1269ef4790d364ccfb1788215039632671d978f8.tar.gz
gentoo-1269ef4790d364ccfb1788215039632671d978f8.tar.bz2
gentoo-1269ef4790d364ccfb1788215039632671d978f8.zip
dev-python/pygame_sdl2: version bump
Based on ebuild by Alex <barracuda72@bk.ru>, bug 587872. Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
-rw-r--r--dev-python/pygame_sdl2/Manifest1
-rw-r--r--dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pygame_sdl2/Manifest b/dev-python/pygame_sdl2/Manifest
index e95c3c29fa2f..040242fae792 100644
--- a/dev-python/pygame_sdl2/Manifest
+++ b/dev-python/pygame_sdl2/Manifest
@@ -1 +1,2 @@
+DIST pygame_sdl2-2.1.0-for-renpy-6.99.12.4.tar.gz 2294620 SHA256 8e9e101027bfab62d6a4b9a4d5705d168383501af9ba958aaa3135233009bd1d SHA512 eacce553d6729b937c13420d826f2fe327bc7aba499a06bea7f1ceedba3327a9456c023878290ace39e1a8e417f54957345b8b78500ffc9ed3d2ec9952397754 WHIRLPOOL e78d83ee974d4338764e60b844d423534e8a616695f8995d06146a85b1421f77c1a9064c00703de357838fdb1aca1ad809a314d68c2aabcf1ddc744e301332cc
DIST pygame_sdl2-for-renpy-6.99.6.tar.bz2 133501 SHA256 a6ae1891a3a7fcbf9c4486da708dd90fbfb5d5c489790f0de8985ec07e695403 SHA512 de1a40f7e8acdb46a7e0b13250c7fffdf848bd44c07408928aab6214afbc741aa77e1e8314d9049324328d9ffc645cafe077a468457a721f36e49f98e5217d53 WHIRLPOOL 0e13889f95323cb9ca2315b2915584c53f3578eb959a713802874c101c405c44e9b3b757ead86a2dbaa56b12d031f12ffbd12bc6776804fe1cb6efaec0246ab6
diff --git a/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4.ebuild b/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4.ebuild
new file mode 100644
index 000000000000..407191d20494
--- /dev/null
+++ b/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+PYSDL="${PN}-2.1.0"
+
+DESCRIPTION="Reimplementation of portions of the pygame API using SDL2"
+HOMEPAGE="https://github.com/renpy/pygame_sdl2"
+SRC_URI="http://www.renpy.org/dl/${PV}/${PYSDL}-for-renpy-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/libpng:0
+ media-libs/libsdl2[video]
+ media-libs/sdl2-image[png,jpeg]
+ media-libs/sdl2-mixer
+ media-libs/sdl2-ttf
+ virtual/jpeg:62
+"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${PYSDL}-for-renpy-${PV}
+
+# PyGame distribution for this version has some pregenerated files;
+# we need to remove them
+python_prepare_all()
+{
+ rm -r "${S}"/gen{,3} || die
+ distutils-r1_python_prepare_all
+}