summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-07 09:32:09 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-07 10:16:01 +0100
commit126eae527d1caba221c9bc664cc185e91948b28c (patch)
tree4315b0f101a1ae95ed5ea3787ac7423ffcdd92d2
parentwww-client/firefox-bin: (security) bump to 78.6.1 (diff)
downloadgentoo-126eae527d1caba221c9bc664cc185e91948b28c.tar.gz
gentoo-126eae527d1caba221c9bc664cc185e91948b28c.tar.bz2
gentoo-126eae527d1caba221c9bc664cc185e91948b28c.zip
dev-python/botocore: Bump to 1.19.50
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.19.50.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 952464684dd8..64bc22951677 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -11,3 +11,4 @@ DIST botocore-1.19.46.tar.gz 7377742 BLAKE2B c80c6f3a21e4d460d4be198762dad440557
DIST botocore-1.19.47.tar.gz 7378319 BLAKE2B e560a191221f6fe617ab700ac9d1f474312bcb278b1641ca1c80090288bea2aa8f9e0b5ac30607c987f409b574b02c445456835f6360fd77f1fc3403647c5b09 SHA512 06b363be4f380ba7061397f93f4f9d11f4c8302430030fd806a812d75caf7fa28c1d24abe4f06eb76e37d1ac9972bcef9231f3330c9f96e7ab66cc8f7ecd96a1
DIST botocore-1.19.48.tar.gz 7379483 BLAKE2B d5848c04dcced3d55a634026ae295133e5c5ea01f86d6545e9d32c7f4a289ba2bf256b6d9dba2ea38ef5b2bc1c76b3c57e0168c178d74fa36c1d661990719c35 SHA512 d7d7992de4e4833a8b043597cb8c5de22b19fe375f2b15549d30eb2ef9e145c056fb16333f1b1feb44b946cdca64944bd91cc10028b726b19df9398f992df183
DIST botocore-1.19.49.tar.gz 7381364 BLAKE2B 19783458b01c31513ec6da85db47a157a874ab328552eb5c9b335dba0e1135a2ac91b73d2d92eafb368ed15cb793903907825ced57a16df82bb8156a0995ec7e SHA512 b699597f415ebc30915ee2f7bb562b082e289ce7628125797a994b9f116869f2c73fb8d686950253fd6dc045330c298131f42555525a23d883187c2256877373
+DIST botocore-1.19.50.tar.gz 7382888 BLAKE2B 7de2ef7a7d051427191b13cdd47d3ebd9b4de505e3e17aa7dfb42de9a5eebffa2f06317a559631d219acc4380cc68c7dcfa1d6b0dc9cb123b2fa0315dd81df4e SHA512 7d1a8ff53e22fc265d8ac6492c0607f8948c9aa5862abaded93c605c3a3e4e98e535308e5ec1500a480636e03dbc3d849ec2b1dbf0efb22dffa841ce1cb551f9
diff --git a/dev-python/botocore/botocore-1.19.50.ebuild b/dev-python/botocore/botocore-1.19.50.ebuild
new file mode 100644
index 000000000000..fa25adc1c1ff
--- /dev/null
+++ b/dev-python/botocore/botocore-1.19.50.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}