summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-27 19:44:56 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-27 19:44:56 +0100
commit1272c3b742a24284ddd068d7bf097be00c0277a7 (patch)
tree531ad3441ab630cdc0dd45ea992fae1035ce902a
parentdev-python/google-api-python-client: Remove old (diff)
downloadgentoo-1272c3b7.tar.gz
gentoo-1272c3b7.tar.bz2
gentoo-1272c3b7.zip
dev-python/httpcore: Relax the dev-python/h11 dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/httpcore/httpcore-0.14.7-r1.ebuild (renamed from dev-python/httpcore/httpcore-0.14.7.ebuild)8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/httpcore/httpcore-0.14.7.ebuild b/dev-python/httpcore/httpcore-0.14.7-r1.ebuild
index 44f405586310..396c0c27cbe0 100644
--- a/dev-python/httpcore/httpcore-0.14.7.ebuild
+++ b/dev-python/httpcore/httpcore-0.14.7-r1.ebuild
@@ -5,6 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
+
inherit distutils-r1 optfeature
DESCRIPTION="A minimal low-level HTTP client"
@@ -20,7 +21,7 @@ KEYWORDS="amd64 arm arm64 hppa ppc ppc64 ~riscv sparc x86"
RDEPEND="
=dev-python/anyio-3*[${PYTHON_USEDEP}]
dev-python/certifi[${PYTHON_USEDEP}]
- <dev-python/h11-0.13[${PYTHON_USEDEP}]
+ <dev-python/h11-0.14[${PYTHON_USEDEP}]
<dev-python/h2-5[${PYTHON_USEDEP}]
=dev-python/sniffio-1*[${PYTHON_USEDEP}]
"
@@ -37,6 +38,11 @@ BDEPEND="
distutils_enable_tests pytest
+src_prepare() {
+ sed -i -e '/h11/s:,<0.13::' setup.py || die
+ distutils-r1_src_prepare
+}
+
pkg_postinst() {
optfeature "SOCKS support" dev-python/socksio
}