summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-03 11:50:25 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-03 14:04:41 +0200
commit127d959e94b1d1b5da2c5ea63d1039a8b41ec49d (patch)
tree230486d7620d3d7f0e5d133ce0420b692f346c5f
parentdev-python/botocore: Bump to 1.27.66 (diff)
downloadgentoo-127d959e.tar.gz
gentoo-127d959e.tar.bz2
gentoo-127d959e.zip
dev-python/boto3: Bump to 1.24.66
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.24.66.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index c4f66132d2c2..e23706c4e511 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.24.61.gh.tar.gz 531957 BLAKE2B b8cff8dea6b74ce1238a734cf1e2fb41ede2
DIST boto3-1.24.63.gh.tar.gz 533004 BLAKE2B f678fbea81cf1be2f28d2463fbf50ff841d0a2c027f2f80cb99364b686aa8b72cd02345e6f8532e2d3b2b6c4a676f50640e1c3d3fc50d53a1aa549d90b8f7bc0 SHA512 771b3911180df5bc85b0ee1a4b8762bf387a1f55f37501b8b10bb3971e5cfb91fb072c4f9ea405d16b6351b1d34c8dce6e9564dfabd2414f6162ca8cc5ba3bc9
DIST boto3-1.24.64.gh.tar.gz 533638 BLAKE2B 1cf4774e17226b453aec3203eea6f343e0921f0ec95669a13788303176da571d467fdf6d558201b449a426e450bfd932b0a79f773f029495e3be6451c07ab9f9 SHA512 6d844b57cf751ff40ad7efa3b4f1f2ec3f00aca2cdf43524a30282a4347f52e1e7cb7762085740b9c3d5e16331b5a1b6b1e2de09904f7d1fabde903c8f8258c3
DIST boto3-1.24.65.gh.tar.gz 533830 BLAKE2B 10ff261500c010449f281bdd6c2767910519026b8e6a9ef93a36a2d6c9fdb39b1d8b15585a3eae615d96a8b19c63c9eecd88a8c08dca974ff5b233933bb72fdd SHA512 588426a35b4764d05434593538afb245fbfb9e1626e0f0fc86741e83c9662331930bfd4e267f132a01742304bbf70fc71998b61146bee4e215600d6ac26a7afa
+DIST boto3-1.24.66.gh.tar.gz 534375 BLAKE2B 3a922be7a1736af8d37a11b62f444601e8e822b2ccb937e2e295332a102abd3def304a80c432664504f81bbf1a95aad635226073ad93c194ff96a99ad4ad60d4 SHA512 ae11b8a5247f7a9ad2c222e5e52bae27e7686ad2228e815e9c5f755ec57d1d3e2f805b6f4875edc791dfd4e783f80e0045ca34ceb2cf3dfd5831a086d9a8eb20
diff --git a/dev-python/boto3/boto3-1.24.66.ebuild b/dev-python/boto3/boto3-1.24.66.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.24.66.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}