summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-16 08:09:44 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-16 08:09:44 +0200
commit1283e93da92160298882096bb9184be63ecef3d2 (patch)
tree1776bb939b1cb7377658b7cdec9f5e9f4f5522cc
parentdev-python/pkginfo: Remove old (diff)
downloadgentoo-1283e93da92160298882096bb9184be63ecef3d2.tar.gz
gentoo-1283e93da92160298882096bb9184be63ecef3d2.tar.bz2
gentoo-1283e93da92160298882096bb9184be63ecef3d2.zip
dev-python/pyopencl: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyopencl/Manifest1
-rw-r--r--dev-python/pyopencl/pyopencl-2021.1.3.ebuild57
2 files changed, 0 insertions, 58 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index f74a74ce907e..6cba7f1e930c 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,2 +1 @@
-DIST pyopencl-2021.1.3.tar.gz 447070 BLAKE2B fcd8c5d06de9c14a7bcf3c3d37f89cb208adf0225cc88a081aefc86aac82a99026183f2c9975f34cd8247f784335e4ba6c0a09164ce01e527123b5c1dd952a76 SHA512 8799e73b3b1596387f619fd997f643228679fb1d9ab5ce6704da9df51922f96229efc98ab6b7a7361234848078b15bc67946a4188f4d17cb8760040b48b346e8
DIST pyopencl-2021.2.6.tar.gz 450194 BLAKE2B be9d0bf653f77d33a4337deab9189a5a9031ff50526444283c6fb9f8625d0451cb211ff703b5eb86c18beebb973f8f7a7cc93da3efc6bb4e95cd533d633fde93 SHA512 b7bea4903a34104c538545c611554c1651ae7a94ee56d8c7129a88a9e547911fac085617b4238fac33534c9b981bcfdb9fabd716456a86fa428cfd42d9cb128c
diff --git a/dev-python/pyopencl/pyopencl-2021.1.3.ebuild b/dev-python/pyopencl/pyopencl-2021.1.3.ebuild
deleted file mode 100644
index 103b128915c0..000000000000
--- a/dev-python/pyopencl/pyopencl-2021.1.3.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="https://mathema.tician.de/software/pyopencl/
- https://pypi.org/project/pyopencl/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="examples opengl"
-
-COMMON="dev-python/numpy[${PYTHON_USEDEP}]
- >=virtual/opencl-2"
-RDEPEND="${COMMON}
- >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- >=dev-python/pytools-2017.6[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
-DEPEND="${COMMON}
- dev-python/pybind11[${PYTHON_USEDEP}]
- opengl? ( media-libs/libglvnd )"
-
-# The test suite fails if there are no OpenCL platforms available, and
-# even if there is one (which requires the presence of both an OpenCL
-# runtime *and* hardware supported by it - simply emerging any runtime
-# is not enough) the vast majority of tests end up skipped because by
-# default the portage user hasn't got sufficient privileges to talk
-# to the GPU.
-RESTRICT="test"
-
-python_configure_all() {
- local myconf=()
- if use opengl; then
- myconf+=(--cl-enable-gl)
- fi
-
- "${EPYTHON}" configure.py \
- "${myconf[@]}"
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}