summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-03-19 00:43:14 -0400
committerMatt Turner <mattst88@gentoo.org>2024-03-19 01:06:16 -0400
commit128496a4717fb4085ea09066b92f53ae47e0341a (patch)
treef5dfa7b542657092932338e5cd3943a0a9b7c7c5
parentdev-libs/libei: Stabilize 1.2.1 arm, #927261 (diff)
downloadgentoo-128496a4717fb4085ea09066b92f53ae47e0341a.tar.gz
gentoo-128496a4717fb4085ea09066b92f53ae47e0341a.tar.bz2
gentoo-128496a4717fb4085ea09066b92f53ae47e0341a.zip
sys-fs/squashfs-tools-ng: Version bump to 1.3.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--sys-fs/squashfs-tools-ng/Manifest1
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.3.0.ebuild52
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild2
3 files changed, 54 insertions, 1 deletions
diff --git a/sys-fs/squashfs-tools-ng/Manifest b/sys-fs/squashfs-tools-ng/Manifest
index 697696ca16bf..ef74757014f2 100644
--- a/sys-fs/squashfs-tools-ng/Manifest
+++ b/sys-fs/squashfs-tools-ng/Manifest
@@ -1 +1,2 @@
DIST squashfs-tools-ng-1.2.0.tar.xz 586992 BLAKE2B ca20e4e01033b4dfa3ada2abd0f618305cb3f49f683863d36ea93679c2cfc0c396ee209c3254fa318d30cb2c4c000c3634d4b625212842cabae0a5e53b4a2bdc SHA512 0c52890a92e2aee928db3e2407c087703d331e9dd8cba1b58ef44fe78cdd7ed1523e9b0485f7da83ad77423ffdccaf392a2b752ad948d62a5f1b5e600b523070
+DIST squashfs-tools-ng-1.3.0.tar.xz 585800 BLAKE2B 658ff825b2cda63116c29d8c582f54df5bd511a6da98e737527d54720ed95a541edc39b94f61195f4c99d125cbcc8db824ea9d1e2a7a7a557fb647f5e795d623 SHA512 10ddff837464227d97c3c2dabeefa408a63fbab4ddc8ca184f4ecce7288ac47c0c6baf6d10146f7e29e4a845592720e39281f779420f5ba0b1e7736c0dea73d7
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.3.0.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.3.0.ebuild
new file mode 100644
index 000000000000..161eca8ce48e
--- /dev/null
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.3.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A new set of tools for working with SquashFS images"
+HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
+if [[ ${PV} = 9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
+fi
+
+LICENSE="LGPL-3+ BSD-2 MIT tools? ( GPL-3+ )"
+SLOT="0"
+IUSE="lz4 +lzma lzo selinux +tools zstd"
+
+DEPEND="
+ app-arch/bzip2:=
+ sys-libs/zlib:=
+ lz4? ( app-arch/lz4:= )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo:2 )
+ selinux? ( sys-libs/libselinux:= )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_with lz4)
+ $(use_with lzo)
+ $(use_with selinux)
+ $(use_with tools)
+ $(use_with lzma xz)
+ $(use_with zstd)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild
index 76778f0ce58b..161eca8ce48e 100644
--- a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2023 Gentoo Authors
+# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8