summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2023-12-24 01:35:43 +0200
committerMart Raudsepp <leio@gentoo.org>2023-12-24 01:35:51 +0200
commit1288c75b91944dc3cc5d113c033c4937c5153f0c (patch)
treef19a42269fe86bf471710216ec1ee39b570c6db7
parentsys-kernel/gentoo-sources: drop 6.6.4 (diff)
downloadgentoo-1288c75b.tar.gz
gentoo-1288c75b.tar.bz2
gentoo-1288c75b.zip
dev-python/python-dbusmock: add 0.30.1
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--dev-python/python-dbusmock/Manifest1
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.30.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/python-dbusmock/Manifest b/dev-python/python-dbusmock/Manifest
index 40c765e070aa..da126c357e7b 100644
--- a/dev-python/python-dbusmock/Manifest
+++ b/dev-python/python-dbusmock/Manifest
@@ -1 +1,2 @@
DIST python-dbusmock-0.30.0.tar.gz 98201 BLAKE2B eb519dc526d4e3ab804c3415d223d77462e944bac8d03dd64fbe11f8a5d875ebad1643230b93d1d51cd4a979eed24e6b97d0744b115d28d233b4d1239ec04f01 SHA512 280a8ebfe12a0f5b309d5b807547ed521c80c9899fdc89abaaee238621cf94d05f8413ab2908ca331f9d3ef1c610234dafbd912f8590f18c7d9cafe470beece6
+DIST python-dbusmock-0.30.1.tar.gz 98206 BLAKE2B e7617e61f2dcd28ba01f5a4572250f1be756640a7751353c5adabc7539897a8f2dce1bf0f0233ed6dec52703d0cf989ff0dbdc3a526a299691f94ee227a3167a SHA512 dfa27c94d71e132ef56615cc02f2f9733ca55366b5e88f023ddc594b39c2239b460389e4b53981493d627e8c117542fa5ec82f0f4ec407ed6e825e30f5d206ae
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.30.1.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.30.1.ebuild
new file mode 100644
index 000000000000..e91d1001c936
--- /dev/null
+++ b/dev-python/python-dbusmock/python-dbusmock-0.30.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="
+ https://github.com/martinpitt/python-dbusmock/
+ https://pypi.org/project/python-dbusmock/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # linter tests, fragile to newer linter versions
+ tests/test_code.py
+)
+
+src_prepare() {
+ # dev-python/dbus-python uses autotools, so no .dist-info there
+ sed -i '/dbus-python/d' pyproject.toml setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # Tests break if XDG_DATA_DIRS is modified by flatpak install
+ unset XDG_DATA_DIRS
+ distutils-r1_python_test
+}