summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-12 22:09:51 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-12 22:09:51 +0100
commit12ad9b4aab7ec89cb7eb39091c2266a9777aefeb (patch)
treed4f41beca4b469ed8725d5737d88a8ac9fbd8bd5
parentdev-libs/tree-sitter: Remove hardcoded libdir (diff)
downloadgentoo-12ad9b4aab7ec89cb7eb39091c2266a9777aefeb.tar.gz
gentoo-12ad9b4aab7ec89cb7eb39091c2266a9777aefeb.tar.bz2
gentoo-12ad9b4aab7ec89cb7eb39091c2266a9777aefeb.zip
xfce-base/thunar: Bump to 4.16.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-base/thunar/Manifest1
-rw-r--r--xfce-base/thunar/thunar-4.16.2.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/xfce-base/thunar/Manifest b/xfce-base/thunar/Manifest
index 188296d304f8..eed35cadced7 100644
--- a/xfce-base/thunar/Manifest
+++ b/xfce-base/thunar/Manifest
@@ -2,3 +2,4 @@ DIST thunar-1.8.16.tar.bz2 2479718 BLAKE2B 2de72f0b9977a9815c0a7f0376ceb01ddd5a6
DIST thunar-4.15.3.tar.bz2 2445923 BLAKE2B 7c1fcbb77eba1a2198bbfac88d43d9a332941aca9dec46d239933288d6e97d4029208bcbe6574577d71aad11292c2ca8015374502b724fa3e3844f0fa664152b SHA512 a86a2e984ccbec82f50b479efc61334615b0ac116d8b3a479c61470d34fe47bac0d3e327cf4e10a1bf3ad50910abb26767bbd7ffed0cf4263e3435a21e1ab6dd
DIST thunar-4.16.0.tar.bz2 2454813 BLAKE2B 528abf3f3227992dbed23e453205a55dcdda8bf03d242f6668e45e2d22921dfe5f5dd5550a7cdf53fd5c39c21ecf9567bc02e2d178ae7a1d35ad0c4f6932e4a7 SHA512 0f288018ead108c6a170a9b98d45d6c005301eb51526b357ab81411724451f0e6a1154ae44dd7681ee5bc9a8807df1497ed26d1af0ac002d68c69fede808cc51
DIST thunar-4.16.1.tar.bz2 2447673 BLAKE2B 6a0533fb052c9cb1e478145685859e22fb3134aee4332e4bf23d3c9addaa17e1514ebf3e8087474cdc728d44a52d43a15d1b10a62e3a3c6e1654404097461957 SHA512 aa579682cb6fc9af339ae40a6fdd66e49d34ae849388384af5665499c3b58f59a628a8380bd174d0988249139a7f7783cb3fa5342e1b019e8d2e0c044ea8f6d0
+DIST thunar-4.16.2.tar.bz2 2434525 BLAKE2B e50fb41d7d333fe23729ddc01ce7e1313124ad3607e0e57fd210794b21f83fb83cd2a4ef9845638c0e10ceb5995392b754991600fc242e4a7e11af6a55971624 SHA512 761bc2b2106db523b5b56b9f330a42e487aeccd144d2118956a67d6935ee6d795edf543a815c3e035dd7cc4b0965679811d39d9c5e6b6f7ca84eb362f22561e0
diff --git a/xfce-base/thunar/thunar-4.16.2.ebuild b/xfce-base/thunar/thunar-4.16.2.ebuild
new file mode 100644
index 000000000000..98de1a3775ac
--- /dev/null
+++ b/xfce-base/thunar/thunar-4.16.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="File manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/ https://docs.xfce.org/xfce/thunar/start"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="exif introspection libnotify pcre +trash-panel-plugin udisks"
+
+GVFS_DEPEND=">=gnome-base/gvfs-1.18.3"
+DEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.50
+ >=x11-libs/gdk-pixbuf-2.14
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/exo-0.12:=
+ >=xfce-base/libxfce4ui-4.15.3:=
+ >=xfce-base/libxfce4util-4.15.2:=
+ >=xfce-base/xfconf-4.12:=
+ exif? ( >=media-libs/libexif-0.6.19:= )
+ introspection? ( dev-libs/gobject-introspection:= )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ pcre? ( >=dev-libs/libpcre-6:= )
+ trash-panel-plugin? ( >=xfce-base/xfce4-panel-4.10:= )
+ udisks? ( dev-libs/libgudev:= )"
+RDEPEND="${DEPEND}
+ >=dev-util/desktop-file-utils-0.20-r1
+ x11-misc/shared-mime-info
+ trash-panel-plugin? ( ${GVFS_DEPEND} )
+ udisks? (
+ virtual/udev
+ ${GVFS_DEPEND}[udisks,udev]
+ )"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable udisks gudev)
+ $(use_enable libnotify notifications)
+ $(use_enable exif)
+ $(use_enable pcre)
+ $(use_enable trash-panel-plugin tpa-plugin)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "If you were using an older Xfce version and Thunar fails to start"
+ elog "with a message similar to:"
+ elog " Failed to register: Timeout was reached"
+ elog "you may need to reset your xfce4 session:"
+ elog " rm ~/.cache/sessions/xfce4-session-*"
+ elog "See https://bugs.gentoo.org/698914."
+
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}