summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-26 21:01:20 +0100
committerMichał Górny <mgorny@gentoo.org>2017-01-26 21:14:02 +0100
commit12b15ac08c9b73f866b8ce72346d518a836a483d (patch)
tree4642dd25a8a9883872e141f41a20ff81ef19d8f0
parentdev-python/miniupnpc: Bump to 2.0.20161216 (diff)
downloadgentoo-12b15ac08c9b73f866b8ce72346d518a836a483d.tar.gz
gentoo-12b15ac08c9b73f866b8ce72346d518a836a483d.tar.bz2
gentoo-12b15ac08c9b73f866b8ce72346d518a836a483d.zip
net-misc/miniupnpd: Bump to 2.0.20161216
-rw-r--r--net-misc/miniupnpd/Manifest1
-rw-r--r--net-misc/miniupnpd/miniupnpd-2.0.20161216.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/net-misc/miniupnpd/Manifest b/net-misc/miniupnpd/Manifest
index a384c0ee7057..3df3ed90bc65 100644
--- a/net-misc/miniupnpd/Manifest
+++ b/net-misc/miniupnpd/Manifest
@@ -1 +1,2 @@
+DIST miniupnpd-2.0.20161216.tar.gz 218119 SHA256 9e73d50ac830b5e08b6eb1df4e4c917833a5ab54351809f615d15d0f30cdeef3 SHA512 af82f060d28033dd670fcc96c8e2895f92d249a8a79d991e0215159eeb57715d7a9152d7d751b836091f7a623ce8a194ea243d1a2fb639349e320c02ce187c27 WHIRLPOOL 478a56b137b86ba1dca70e15c7dbdef2969a2d089e1ae0bac7ff01c18e753c8c3cca8b89ef415d54c3a009b89156eb507e97ba1949223bdd37914042c5124be1
DIST miniupnpd-2.0.tar.gz 217802 SHA256 d96aa3a00e0f5490826bba3cb97e68cd27479e5839adac4b9bcb66eae786bfb7 SHA512 c88036d3f4b065fc855572db8945d921641a71a23ffe8b52cb4ccb1a7cf3e7396841c436d54d7ff5968d034d8c4bfc91630719959000436230bb8c37e5bdc8d4 WHIRLPOOL d6aec880c9ef3c70002fdf9a98a0e8f4de95d8b3c9c6a18e328bc94d7dc3b8c130829c8ea6117e27e5b0aac1cd4526bbc9d9de21bd13e7b5527db54a656a1fff
diff --git a/net-misc/miniupnpd/miniupnpd-2.0.20161216.ebuild b/net-misc/miniupnpd/miniupnpd-2.0.20161216.ebuild
new file mode 100644
index 000000000000..1e69bf17ee9e
--- /dev/null
+++ b/net-misc/miniupnpd/miniupnpd-2.0.20161216.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="MiniUPnP IGD Daemon"
+HOMEPAGE="http://miniupnp.free.fr/"
+SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+leasefile igd2 ipv6 pcp-peer portinuse strict"
+
+RDEPEND=">=net-firewall/iptables-1.4.6:0=[ipv6?]
+ net-libs/libnfnetlink:=
+ net-libs/libmnl:=
+ dev-libs/gmp:0=
+ sys-apps/util-linux
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ sys-apps/lsb-release"
+
+src_prepare() {
+ default
+ mv Makefile.linux Makefile || die
+}
+
+src_configure() {
+ local -a opts
+ opts=(
+ --vendorcfg
+ $(use igd2 && printf -- '--igd2\n')
+ $(use ipv6 && printf -- '--ipv6\n')
+ $(use leasefile && printf -- '--leasefile\n')
+ $(use portinuse && printf -- '--portinuse\n')
+ $(use pcp-peer && printf -- '--pcp-peer\n')
+ $(use strict && printf -- '--strict\n')
+ )
+
+ emake CONFIG_OPTIONS="${opts[*]}" config.h
+}
+
+src_compile() {
+ # By default, it builds a bunch of unittests that are missing wrapper
+ # scripts in the tarball
+ emake CC="$(tc-getCC)" STRIP=true miniupnpd
+}
+
+src_install() {
+ emake PREFIX="${ED}" STRIP=true install
+
+ newinitd "${FILESDIR}"/${PN}-init.d-r1 ${PN}
+ newconfd "${FILESDIR}"/${PN}-conf.d-r1 ${PN}
+}
+
+pkg_postinst() {
+ elog "Please correct the external interface in the top of the two"
+ elog "scripts in /etc/miniupnpd and edit the config file in there too"
+}