summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2021-09-02 00:41:17 -1000
committerMarc Schiffbauer <mschiff@gentoo.org>2021-09-02 00:45:00 -1000
commit12bd62a0066c71a35b4ee35b064a6f79270839ac (patch)
tree11207ecb6bed31b170d04553df131dbf498f7ed7
parentdev-util/cmake: Drop 3.18.5 (diff)
downloadgentoo-12bd62a0.tar.gz
gentoo-12bd62a0.tar.bz2
gentoo-12bd62a0.zip
net-dns/unbound: add tfo USE flag
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
-rw-r--r--net-dns/unbound/metadata.xml3
-rw-r--r--net-dns/unbound/unbound-1.13.2.ebuild6
2 files changed, 5 insertions, 4 deletions
diff --git a/net-dns/unbound/metadata.xml b/net-dns/unbound/metadata.xml
index b125fb7df610..844b7d8ad1dd 100644
--- a/net-dns/unbound/metadata.xml
+++ b/net-dns/unbound/metadata.xml
@@ -30,7 +30,8 @@
<flag name="ecs">Enable EDNS client subnet support</flag>
<flag name="gost">Enable GOST support</flag>
<flag name="http2">Enable HTTP/2 support for DoH<pkg>net-libs/nghttp2</pkg></flag>
- <flag name="redis">Enable cache db backend which uses <pkg>dev-libs/hiredis</pkg></flag>
+ <flag name="redis">Enable cache db backend which uses<pkg>dev-libs/hiredis</pkg></flag>
+ <flag name="tfo">Enable TCP Fast Open client+server</flag>
</use>
<upstream>
<remote-id type="github">NLnetLabs/unbound</remote-id>
diff --git a/net-dns/unbound/unbound-1.13.2.ebuild b/net-dns/unbound/unbound-1.13.2.ebuild
index 83b74f7345dc..4e61650bf380 100644
--- a/net-dns/unbound/unbound-1.13.2.ebuild
+++ b/net-dns/unbound/unbound-1.13.2.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://nlnetlabs.nl/downloads/unbound/${MY_P}.tar.gz"
LICENSE="BSD GPL-2"
SLOT="0/8" # ABI version of libunbound.so
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~x86"
-IUSE="debug dnscrypt dnstap +ecdsa ecs gost +http2 python redis selinux static-libs systemd test threads"
+IUSE="debug dnscrypt dnstap +ecdsa ecs gost +http2 python redis selinux static-libs systemd test +tfo threads"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RESTRICT="!test? ( test )"
@@ -100,12 +100,12 @@ multilib_src_configure() {
$(multilib_native_use_with python pyunbound) \
$(use_with threads pthreads) \
$(use_with http2 libnghttp2) \
+ $(use_enable tfo tfo-client) \
+ $(use_enable tfo tfo-server) \
--disable-flto \
--disable-rpath \
--enable-event-api \
--enable-ipsecmod \
- --enable-tfo-client \
- --enable-tfo-server \
--with-libevent="${EPREFIX}"/usr \
$(multilib_native_usex redis --with-libhiredis="${EPREFIX}/usr" --without-libhiredis) \
--with-pidfile="${EPREFIX}"/run/unbound.pid \