summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-30 13:53:31 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-30 14:09:35 +0100
commit12c09d23b4b2a9407e76048f33fb597f51225181 (patch)
treecd47875180eb8e33e4e7260020f27fb41794eb9a
parentdev-python/traitlets: Switch to PEP 517 build (diff)
downloadgentoo-12c09d23b4b2a9407e76048f33fb597f51225181.tar.gz
gentoo-12c09d23b4b2a9407e76048f33fb597f51225181.tar.bz2
gentoo-12c09d23b4b2a9407e76048f33fb597f51225181.zip
dev-python/unittest-or-fail: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/unittest-or-fail/unittest-or-fail-1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/unittest-or-fail/unittest-or-fail-1-r1.ebuild b/dev-python/unittest-or-fail/unittest-or-fail-1-r1.ebuild
new file mode 100644
index 000000000000..f12c75497b62
--- /dev/null
+++ b/dev-python/unittest-or-fail/unittest-or-fail-1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Run unittests or fail if no tests were found"
+HOMEPAGE="https://github.com/mgorny/unittest-or-fail/"
+SRC_URI="
+ https://github.com/mgorny/unittest-or-fail/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Warning: do not use distutils_enable_tests to avoid a circular
+# dependency on itself!
+python_test() {
+ "${EPYTHON}" -m unittest -v test/test_unittest_or_fail.py ||
+ die "Tests failed with ${EPYTHON}"
+}