summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-11-22 20:55:49 -0500
committerMike Gilbert <floppym@gentoo.org>2020-11-22 20:57:27 -0500
commit12d36ad8ddbf9a7ac37feb4b7f51b48e93d3906c (patch)
tree80666c22a17b53a7427ff5d561846304004c910a
parentnet-dns/c-ares: Stabilize 1.17.1 ppc64, #754939 (diff)
downloadgentoo-12d36ad8.tar.gz
gentoo-12d36ad8.tar.bz2
gentoo-12d36ad8.zip
dev-libs/dbus-glib: fix cross-compiles
Thanks to David Michael for the ebuild changes Closes: https://bugs.gentoo.org/346353 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--dev-libs/dbus-glib/dbus-glib-0.110.ebuild28
1 files changed, 21 insertions, 7 deletions
diff --git a/dev-libs/dbus-glib/dbus-glib-0.110.ebuild b/dev-libs/dbus-glib/dbus-glib-0.110.ebuild
index 9e47f93d6afc..fad3e34a6eb4 100644
--- a/dev-libs/dbus-glib/dbus-glib-0.110.ebuild
+++ b/dev-libs/dbus-glib/dbus-glib-0.110.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit bash-completion-r1 eutils ltprune multilib-minimal
+EAPI=7
+inherit bash-completion-r1 multilib-minimal
DESCRIPTION="D-Bus bindings for glib"
HOMEPAGE="https://dbus.freedesktop.org/"
@@ -14,17 +14,20 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd6
IUSE="debug static-libs test"
RESTRICT="!test? ( test )"
-CDEPEND="
+DEPEND="
>=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}]
>=dev-libs/glib-2.40:2[${MULTILIB_USEDEP}]
>=sys-apps/dbus-1.8[${MULTILIB_USEDEP}]
"
-DEPEND="${CDEPEND}
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-libs/expat-2.1.0-r3
+ >=dev-libs/glib-2.40:2
+ >=sys-apps/dbus-1.8
>=dev-util/glib-utils-2.40
>=dev-util/gtk-doc-am-1.14
virtual/pkgconfig
-"
-RDEPEND="${CDEPEND}"
+" # CBUILD dependencies are needed to make a native tool while cross-compiling.
DOCS=( AUTHORS ChangeLog HACKING NEWS README )
@@ -42,6 +45,15 @@ multilib_src_configure() {
$(use_enable static-libs static)
)
+ # Configure a CBUILD directory to make a native build tool.
+ if tc-is-cross-compiler; then
+ mkdir "${BUILD_DIR}-build" || die
+ cd "${BUILD_DIR}-build" || die
+ ECONF_SOURCE="${S}" econf_build
+ myconf+=( --with-dbus-binding-tool="$PWD/dbus/dbus-binding-tool" )
+ cd - || die
+ fi
+
ECONF_SOURCE="${S}" econf "${myconf[@]}"
ln -s "${S}"/doc/reference/html doc/reference/html || die #460042
@@ -60,6 +72,8 @@ multilib_src_configure() {
}
multilib_src_compile() {
+ tc-is-cross-compiler && emake -C "${BUILD_DIR}-build"
+
emake
if use test; then
@@ -82,5 +96,5 @@ multilib_src_install_all() {
newbashcomp "${ED}"/etc/bash_completion.d/dbus-bash-completion.sh dbus-send
rm -rf "${ED}"/etc/bash_completion.d || die
- prune_libtool_files
+ find "${ED}" -type f -name '*.la' -delete || die
}