summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2022-02-17 13:04:54 +0100
committerSam James <sam@gentoo.org>2022-03-21 23:45:20 +0000
commit12e0ad5934e29398004185958820f3fc3df984b2 (patch)
tree94e5ee8bbf773f202ca07353147d8d77b5293ab3
parentmate-extra/mate-user-guide: add 1.26.0 (diff)
downloadgentoo-12e0ad5934e29398004185958820f3fc3df984b2.tar.gz
gentoo-12e0ad5934e29398004185958820f3fc3df984b2.tar.bz2
gentoo-12e0ad5934e29398004185958820f3fc3df984b2.zip
mate-base/libmatekbd: add 1.26.0
Signed-off-by: Oz N Tiram <oz.tiram@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--mate-base/libmatekbd/Manifest1
-rw-r--r--mate-base/libmatekbd/libmatekbd-1.26.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/mate-base/libmatekbd/Manifest b/mate-base/libmatekbd/Manifest
index 521846e9db0d..892cdc5a5441 100644
--- a/mate-base/libmatekbd/Manifest
+++ b/mate-base/libmatekbd/Manifest
@@ -1 +1,2 @@
DIST libmatekbd-1.24.1.tar.xz 451404 BLAKE2B b05c469aabef69ba091ed4d9bdb4c207ed7f2042413c701d4a864cc514f1cc5b37b3750f01db544bf28fca712776a42262e6036043c5c1a9632789bf2f23d029 SHA512 982f973e90bd08c4068fc42f6c62d9d32f8ba4855f5616b3e4ce7167df787bd9dacf47fac3d95ddd0e7d622870bc394c1a22cfb929d0f3293c26095c2b5fe7e3
+DIST libmatekbd-1.26.0.tar.xz 453996 BLAKE2B 42b3933d27bde000cc599ba42223f01312db7d9b7a395378af4def91063dcdedeff66be43d35e6a763826c3fc0eafd354731c634a73a1d0b524a0cff6e38cc2d SHA512 1e8bdb331ecb97ccd54931ac59f0692af8665e7c0499a62b25ac69cfc6af1196b5198d707ef5e3985d8fe837a0813a014802b00760d32924af4f38b0df4b8b65
diff --git a/mate-base/libmatekbd/libmatekbd-1.26.0.ebuild b/mate-base/libmatekbd/libmatekbd-1.26.0.ebuild
new file mode 100644
index 000000000000..c11ca8db9d5c
--- /dev/null
+++ b/mate-base/libmatekbd/libmatekbd-1.26.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE keyboard configuration library"
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+
+IUSE="X +introspection test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.50:2
+ virtual/libintl
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2.24:2
+ x11-libs/libX11
+ >=x11-libs/libxklavier-5.2:0[introspection?]
+ x11-libs/pango
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+
+RDEPEND="${COMMON_DEPEND}"
+
+BDEPEND="${COMMON_DEPEND}
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ $(use_with X x) \
+ $(use_enable introspection) \
+ $(use_enable test tests)
+}