summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-06-25 22:23:16 +0200
committerTony Vroon <chainsaw@gentoo.org>2018-07-11 12:42:43 +0100
commit12e438e749a87f98032e15523adf16df97bf4ce4 (patch)
tree6f45813929557413b2887c178ec847a72e9cc3a8
parentmedia-libs/xine-lib: remove unused patches (diff)
downloadgentoo-12e438e7.tar.gz
gentoo-12e438e7.tar.bz2
gentoo-12e438e7.zip
net-misc/igmpproxy: bump to version 0.2.1
Closes: https://bugs.gentoo.org/659184 Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9015 Closes: https://bugs.gentoo.org/659184
-rw-r--r--net-misc/igmpproxy/Manifest1
-rw-r--r--net-misc/igmpproxy/files/igmpproxy.confd5
-rw-r--r--net-misc/igmpproxy/files/igmpproxy.initd20
-rw-r--r--net-misc/igmpproxy/files/igmpproxy.service9
-rw-r--r--net-misc/igmpproxy/igmpproxy-0.2.1.ebuild25
-rw-r--r--net-misc/igmpproxy/metadata.xml17
6 files changed, 69 insertions, 8 deletions
diff --git a/net-misc/igmpproxy/Manifest b/net-misc/igmpproxy/Manifest
index e90ba0d238df..c98ef32cf52d 100644
--- a/net-misc/igmpproxy/Manifest
+++ b/net-misc/igmpproxy/Manifest
@@ -1,2 +1,3 @@
DIST igmpproxy-0.1.tar.gz 140159 BLAKE2B d4a0fb0f69f1e8c7221ecd2842e95cfa390f54885d5eaaa5c69a32563b318a05540e123d4b19cd63a930d17934c1344fdf6467fad5c1de333d03e0a802e7912b SHA512 1a569814d8984610402313d8c4adb78ff362f82ae28c968a8ba0fb411e12a704d1b51b387111b51517ab8fb2e86952bbd196f27eccd311c11ce288fc6fa25ad4
+DIST igmpproxy-0.2.1.tar.gz 166951 BLAKE2B d47a2b236679c7d05cf453fb5d6dc3a9e4174776845e2a1f71ca28e02c6e6270b5db09eaf5a48581dd85ecca8ff198a3e4b7f84fd61e455fe33c4f60ec079c15 SHA512 17f6891bf49d3e70cdf3930ab1abe6a0ad7b9f12ff2d1cdde3761771988585301f459995ba5ea956c742597de4ce13fbf0ba3c1ae37d13b2eee2a09f16f51ae2
DIST igmpproxy-0.2.tar.gz 170705 BLAKE2B a2a13399995f283fb77b500140c1750ed306511eb5f51a71491edc245c8d8f873809fac9a82dc7ba0be7a7390643d85d7f4a2a8521b3c2c20fb8f09ad33b507d SHA512 a06f95c912456191d0953c08058ccb987120f6b11426d15e329c2de95878b9fc6ee5742b253e2c06b8002771478c382a58a14a0af76fb835ebb1d132b9f34e4f
diff --git a/net-misc/igmpproxy/files/igmpproxy.confd b/net-misc/igmpproxy/files/igmpproxy.confd
new file mode 100644
index 000000000000..cbbc38cb9167
--- /dev/null
+++ b/net-misc/igmpproxy/files/igmpproxy.confd
@@ -0,0 +1,5 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Additional command line options, see igmpproxy(8) for more information
+IGMPPROXY_OPTS=""
diff --git a/net-misc/igmpproxy/files/igmpproxy.initd b/net-misc/igmpproxy/files/igmpproxy.initd
new file mode 100644
index 000000000000..d8f727ba034c
--- /dev/null
+++ b/net-misc/igmpproxy/files/igmpproxy.initd
@@ -0,0 +1,20 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+config="/etc/${RC_SVCNAME}.conf"
+name="IGMPproxy"
+pidfile="/run/${RC_SVCNAME}.pid"
+
+command="igmpproxy"
+command_args="${IGMPPROXY_OPTS} ${config}"
+procname="${RC_SVCNAME}"
+
+start_pre() {
+ if [ ! -f "${config}" ]; then
+ eerror "Please create ${config} before starting ${name}!"
+ return 1
+ else
+ return 0
+ fi
+}
diff --git a/net-misc/igmpproxy/files/igmpproxy.service b/net-misc/igmpproxy/files/igmpproxy.service
index a682bed09e0a..ae949566c9e4 100644
--- a/net-misc/igmpproxy/files/igmpproxy.service
+++ b/net-misc/igmpproxy/files/igmpproxy.service
@@ -1,9 +1,10 @@
[Unit]
-Description=IGMP proxy
-After=network.target
+Description=IGMPproxy
+After=network-online.target
[Service]
-ExecStart=/usr/sbin/igmpproxy /etc/igmpproxy.conf
+ExecStart=igmpproxy /etc/igmpproxy.conf
+Type=simple
[Install]
-WantedBy=multi-user.target
+WantedBy=network.target
diff --git a/net-misc/igmpproxy/igmpproxy-0.2.1.ebuild b/net-misc/igmpproxy/igmpproxy-0.2.1.ebuild
new file mode 100644
index 000000000000..9154819d42db
--- /dev/null
+++ b/net-misc/igmpproxy/igmpproxy-0.2.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd
+
+CONFIG_CHECK="~IP_MULTICAST ~IP_MROUTE"
+
+DESCRIPTION="A multicast routing daemon which uses IGMP forwarding"
+HOMEPAGE="https://github.com/pali/igmpproxy"
+SRC_URI="https://github.com/pali/igmpproxy/releases/download/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/igmpproxy.initd" igmpproxy
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ newconfd "${FILESDIR}/igmpproxy.confd" igmpproxy
+}
diff --git a/net-misc/igmpproxy/metadata.xml b/net-misc/igmpproxy/metadata.xml
index c2e066bde80c..37a86a4c127a 100644
--- a/net-misc/igmpproxy/metadata.xml
+++ b/net-misc/igmpproxy/metadata.xml
@@ -1,12 +1,21 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<longdescription>
- IGMPproxy is a simple dynamic Multicast Routing Daemon using only IGMP signalling.
- It's intended for simple forwarding of Multicast traffic between networks.
+ IGMPproxy is a simple multicast router using only the IGMP protocol.
+ It is intended for forwarding of multicast traffic between networks,
+ like used by IPTV.
</longdescription>
<upstream>
- <remote-id type="sourceforge">igmpproxy</remote-id>
+ <bugs-to>https://github.com/pali/igmpproxy/issues</bugs-to>
+ <remote-id type="github">pali/igmpproxy</remote-id>
</upstream>
</pkgmetadata>