summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-01 20:16:45 +0100
committerSam James <sam@gentoo.org>2022-06-01 20:17:01 +0100
commit1309e3bab51ba812641509a623ab288235ea64f9 (patch)
treee5b8a1c81c1af3f1fd3f7f4623678c7d6497ea3b
parentapp-text/iso-codes: Version bump to 4.10.0 (diff)
downloadgentoo-1309e3bab51ba812641509a623ab288235ea64f9.tar.gz
gentoo-1309e3bab51ba812641509a623ab288235ea64f9.tar.bz2
gentoo-1309e3bab51ba812641509a623ab288235ea64f9.zip
dev-libs/nss: fix build with GCC 13
Closes: https://bugs.gentoo.org/849005 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/nss/files/nss-3.79-gcc-13.patch33
-rw-r--r--dev-libs/nss/nss-3.79-r1.ebuild1
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/nss/files/nss-3.79-gcc-13.patch b/dev-libs/nss/files/nss-3.79-gcc-13.patch
new file mode 100644
index 000000000000..04bd977f3020
--- /dev/null
+++ b/dev-libs/nss/files/nss-3.79-gcc-13.patch
@@ -0,0 +1,33 @@
+https://github.com/nss-dev/nss/commit/edf5cb12af8a4668997b7edb65c7add4a1390b09
+https://bugs.gentoo.org/849005
+
+From: Sergei Trofimovich <slyich@gmail.com>
+Date: Thu, 26 May 2022 08:08:39 +0000
+Subject: [PATCH] Bug 1771273 - cpputil/databuffer.h: add missing <cstdint>
+ include r=nss-reviewers,mt
+
+Without the change build fails on this week's gcc-13 snapshot as:
+
+ ../../cpputil/databuffer.h:20:20: error: 'uint8_t' does not name a type
+ 20 | DataBuffer(const uint8_t* d, size_t l) : data_(nullptr), len_(0) {
+ | ^~~~~~~
+ ../../cpputil/databuffer.h:14:1: note: 'uint8_t' is defined in header '<cstdint>'; did you forget to '#include <cstdint>'?
+ 13 | #include <iostream>
+ +++ |+#include <cstdint>
+ 14 |
+
+Differential Revision: https://phabricator.services.mozilla.com/D147404
+
+--HG--
+extra : moz-landing-system : lando
+--- a/cpputil/databuffer.h
++++ b/cpputil/databuffer.h
+@@ -11,6 +11,7 @@
+ #include <cstring>
+ #include <iomanip>
+ #include <iostream>
++#include <cstdint>
+
+ namespace nss_test {
+
+
diff --git a/dev-libs/nss/nss-3.79-r1.ebuild b/dev-libs/nss/nss-3.79-r1.ebuild
index 0d91f55e8bd4..f0a86b80c6b6 100644
--- a/dev-libs/nss/nss-3.79-r1.ebuild
+++ b/dev-libs/nss/nss-3.79-r1.ebuild
@@ -40,6 +40,7 @@ PATCHES=(
"${FILESDIR}/${PN}-3.53-gentoo-fixups.patch"
"${FILESDIR}/${PN}-3.21-gentoo-fixup-warnings.patch"
"${FILESDIR}/${PN}-3.23-hppa-byte_order.patch"
+ "${FILESDIR}/${PN}-3.79-gcc-13.patch"
)
src_prepare() {